clicompanion fails to start with errors

Asked by Dave Frandin

I installed clicompanion via the ppa several weeks ago, and have found it to VERY useful. In the last several days however, the program fails to start with the following errors:

Traceback (most recent call last):
  File "/usr/bin/clicompanion", line 625, in <module>
    companion = Companion()
  File "/usr/bin/clicompanion", line 535, in __init__
  File "/usr/bin/clicompanion", line 387, in update
IndexError: list index out of range

I've tried uninstalling and reinstalling manually the deb listed on the launchpad page.. I get the same error(s) with this install... I'm not a Python programmer, so I'm not sure whats going on here..


Question information

English Edit question
CLI Companion Edit question
No assignee Edit question
Solved by:
Dave Frandin
Last query:
Last reply:
Revision history for this message
Duane Hinnen (duanedesign) said :

Have you added commands manually to the .clicompanion file? This can sometimes happen if you add commands directly to that file and there is a blank line at the bottom of that file.


Revision history for this message
Dave Frandin (dave-frandin) said :

Yes I had added a few.. I didnt see a blank line at the bottom of the file, but just for fun, removed the .clicompanion file and tried to start the program... That fixed it... Thanks for the tip.. Great program too!!!!