Freshclam says current, ClamTK says out of date.

Asked by Scott Price

Hello again. I was able to get all dependencies covered for 0.95.2 before installing clamtk, but when I run the clamtk, it says the virus signatures date is 7/12. I tried the update (under Help), but won't run until you run freshclam from the terminal. After that, it runs, and says it's updated, but the main clamtk window still says 7/12 and no green checkmark. I ran dpkg reconfigure clamav-base, set the chmod for logs at 600, and chown to clamav, edited the clamd.conf, and when I run freshclam, this is what it looks like:

ClamAV update process started at Mon Jul 20 14:01:19 2009
main.cvd is up to date (version: 51, sigs: 545035, f-level: 42, builder: sven)
daily.cld is up to date (version: 9591, sigs: 52056, f-level: 43, builder: neo)
Trying host (
nonblock_connect: connect timing out (60 secs)
Can't connect to port 80 of host (IP:
Trying host (
Downloading safebrowsing.cvd [100%]
LibClamAV debug: MD5(.tar.gz) = ce6f8b52274079c1cc6fea549c079c52
LibClamAV debug: cli_versig: Decoded signature: ce6f8b52274079c1cc6fea549c079c52
LibClamAV debug: cli_versig: Digital signature is correct.
safebrowsing.cvd updated (version: 6080, sigs: 1322904, f-level: 43, builder: google)
Database updated (1919995 signatures) from (IP:
WARNING: Clamd was NOT notified: Can't connect to clamd through /var/run/clamav/clamd
connect(): No such file or directory
SubmitDetectionStats: No detection records found

Then when I run clamtk (both terminal w/sudo and from desktop menu), still says 7/12. I run update (under Help) again, says VS and GUI up to date, but still no green check mark and still says 7/12.

Am I missing something?


Question information

English Edit question
ClamTk Edit question
No assignee Edit question
Solved by:
Dave M
Last query:
Last reply:
Revision history for this message
Best Dave M (dave-nerd) said :

Hi Scott,

Are you updating with sudo? If so, please don't. I'm thinking you may have selected single-user updates, but may have inadvertently tried to update with "sudo" - which may have changed permissions of your home directory's .clamtk - which means you can't update as a regular user anymore.

What do you get when you type this at the commandline:

ls -ld ~/.clamtk

If it's owned by root, then we need to change the permissions back to "you". So, if your username is scott, you would type this:

sudo chown -R scott.scott ~/.clamtk

Revision history for this message
Scott Price (scottpricepdx-gmail) said :

I guess I did change the owner, so I changed it back. So I ran freshclam from terminal without sudo, and get:

ERROR: Can't open /var/log/freshclam.log in append mode (check permissions!).
ERROR: Problem with internal logger (UpdateLogFile = /var/log/freshclam.log).

Permissions are clamav.prices on /var/log/freshclam.log.

HOWEVER, when I ran the update from under the Help menu, it updated and got the green checkmark.

Thank you very much.

Revision history for this message
Scott Price (scottpricepdx-gmail) said :

Thanks Dave M, that solved my question.