gir1.2-gmenu-3.0:i386 erro while apt update && apt upgrade

Asked by Hikmat Singh on 2019-08-29

Hello this is hikmat i am getting following error while apt update && apt upgrade and sudo apt-get update && sudo apt-get upgrade
i have run lots of command to fix it but i am unable to do so please kindly help me.

ERROR
___________\

oot@kali:~# sudo apt-get install --reinstall sudo
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 1,240 kB/1,309 kB of archives.
After this operation, 0 B of additional disk space will be used.
Get:1 http://ftp.harukasan.org/kali kali-rolling/main i386 sudo i386 1.8.27-1 [1,240 kB]
Fetched 1,240 kB in 2min 24s (8,638 B/s)
(Reading database ... 426918 files and directories currently installed.)
Preparing to unpack .../sudo_1.8.27-1_i386.deb ...
Unpacking sudo (1.8.27-1) over (1.8.27-1) ...
Setting up sudo (1.8.27-1) ...
dpkg: error processing package gir1.2-gmenu-3.0:i386 (--configure):
 package is in a very bad inconsistent state; you should
 reinstall it before attempting configuration
Processing triggers for man-db (2.8.6.1-1) ...
Processing triggers for systemd (242-4) ...
Errors were encountered while processing:
 gir1.2-gmenu-3.0:i386
E: Sub-process /usr/bin/dpkg returned an error code (1)

Question information

Language:
English Edit question
Status:
Answered
For:
Checkbox Edit question
Assignee:
No assignee Edit question
Last query:
2019-08-29
Last reply:
2019-08-29
Manfred Hampl (m-hampl) said : #1

Try
sudo apt-get install --reinstall gir1.2-gmenu-3.0:i386

Can you help with this problem?

Provide an answer of your own, or ask Hikmat Singh for more information if necessary.

To post a message you must log in.