install ceilometer

Asked by ronghui duan

I get a message
"error: Installed distribution python-keystoneclient 0.2.1 conflicts with requirement python-keystoneclient>=0.1.2,<0.2"
When I run
"python install"
The tarball I get is the latest one ceilometer-master.tar.gz
The requirment is "python-keystoneclient>=0.2,<0.3" which make me confuse.
What is the reason? Help need, 3ks.

Question information

English Edit question
Ceilometer Edit question
No assignee Edit question
Solved by:
Doug Hellmann
Last query:
Last reply:
Revision history for this message
Best Doug Hellmann (doug-hellmann) said :

It looks like you have an older version of keystone client installed as a dependency of some other package, so it cannot be upgraded automatically. One of the other OS clients is probably causing the issue, so you could try upgrading the client packages until you get a version of keystoneclient that works with ceilometer.

Revision history for this message
ronghui duan (ronghui-duan) said :

Thanks, this sovled my problem.
What I did are listed below if you met the same problem.
What I installed orginal is folsom release package with Ubuntu12.10. then
1:remove horizon
apt-get remove horizon
2:update all components to g1 version from tarball or source code.
4:reinstall ceilo.

Revision history for this message
Doug Hellmann (doug-hellmann) said :

OK, thanks for those details!

We have been trying to maintain folsom compatibility, but it sounds like maybe we need to have another look at the version of keystoneclient we're using.

Revision history for this message
Aimon Bustardo (aimonb) said :

I to have this issue. Is there a known procedure for fixing this from packages in Ubuntu?

Revision history for this message
Riki Arslan (riki-arslan) said :

Hi Doug,

We are having a similar problem. We are trying to install "ceilometer-2013.1~g2.tar.gz" which presumably has Folsom compatibility.

The requirment is "python-keystoneclient>=0.2,<0.3" and we have the version 2.3.

But, still, setup quits with the following message:

"error: Installed distribution python-keystoneclient 0.2.3 conflicts with requirement python-keystoneclient>=0.1.2,<0.2"

The funny thing is, although pip-requires states "python-keystoneclient>=0.2,<0.3", the error message complains that it is not "python-keystoneclient>=0.1.2,<0.2".

Your help is appreciated.