Searching a network share (Samba)

Asked by Joril on 2014-01-16

Is it possible to have Catfish search a Samba share? I tried using Catfish 0.8.2 on Xubuntu 12.04 (after having mounted the share via the Thunar file manager) but I always get a "no files found"

Question information

Language:
English Edit question
Status:
Needs information
For:
Catfish Edit question
Assignee:
No assignee Edit question
Last query:
2014-03-17
Last reply:
2014-06-29
Joril (jorilx) said : #1

I tried to debug the issue... It looks like the os.walk() method DOES find the shared files, but since it traverses the .gvfs "meta-folder" it thinks that the files are hidden

Sean Davis (bluesabre) said : #2

You're probably right. I'll create a bug related to this item and fix it for the next release. Thanks!

Sean Davis (bluesabre) said : #3

I'm not able to reproduce this, but I have added some code that should make this work. Could you pulling the latest code from trunk and running your test?

bzr pull lp:catfish-search
cd catfish-search
bin/catfish.py

Joril (jorilx) said : #4

I did a

bzr checkout lp:catfish-search
cd catfish-search
./configure
make
bin/catfish.py

but I get a

/usr/lib/python2.7/dist-packages/gi/overrides/Gtk.py:391: Warning: g_object_set_property: construct property "type" for object `Window' can't be set after construction
  Gtk.Window.__init__(self, type=type, **kwds)
Traceback (most recent call last):
  File "bin/catfish.py", line 55, in <module>
    catfish.main()
  File "/home/joril/src/catfish-search/catfish/__init__.py", line 74, in main
    window = CatfishWindow.CatfishWindow()
  File "/home/joril/src/catfish-search/catfish_lib/Window.py", line 49, in __new__
    new_object.finish_initializing(builder)
  File "/home/joril/src/catfish-search/catfish/CatfishWindow.py", line 116, in finish_initializing
    super(CatfishWindow, self).finish_initializing(builder)
  File "/home/joril/src/catfish-search/catfish_lib/Window.py", line 67, in finish_initializing
    button = Gtk.MenuButton()
  File "/usr/lib/python2.7/dist-packages/gi/module.py", line 243, in __getattr__
    return getattr(self._introspection_module, name)
  File "/usr/lib/python2.7/dist-packages/gi/module.py", line 105, in __getattr__
    self.__name__, name))
AttributeError: 'gi.repository.Gtk' object has no attribute 'MenuButton'

Am I missing something?

Joril (jorilx) said : #5

I get the error even with Catfish 1.0.2, installed from the PPA (deb http://ppa.launchpad.net/catfish-search/catfish-stable/ubuntu precise main)

cat&fish (21catsand1) said : #6

Catfish 1.01 bugged ?

Searching my NAS by command: locate -ib samba=
I find the file in an instant : /media/dir1/dir2/dir3/dir4/samba=

Catfish 1.01 right now delivers just local results .

Earlier on catfish did find samba= but it used the find commnd,
the NAS was busy for a while -> rather slow

The previos version v 0.3.2 worked.
The method-switch got abandoned in v 1.01

Can you help with this problem?

Provide an answer of your own, or ask Joril for more information if necessary.

To post a message you must log in.