Latest version on sid errors

Asked by Daniel Letzeisen on 2013-07-19

I run Debian sid along with Catfish built from latest bzr, and though the .deb builds fine, I encounter the following error when trying to run:

$ catfish
Traceback (most recent call last):
  File "bin/catfish.py", line 50, in <module>
    import catfish
  File "/usr/share/catfish/catfish/__init__.py", line 24, in <module>
    from catfish import CatfishWindow
  File "/usr/share/catfish/catfish/CatfishWindow.py", line 37, in <module>
    from catfish_lib import Window, CatfishSettings
ImportError: cannot import name CatfishSettings

I could not reproduce the error on my Xubuntu 13.10 VM, so I'm wondering if something's wrong/missing with my python on Debian or whether something's wrong with Catfish.

Question information

Language:
English Edit question
Status:
Solved
For:
Catfish Edit question
Assignee:
No assignee Edit question
Solved by:
Sean Davis
Solved:
2013-07-27
Last query:
2013-07-27
Last reply:
2013-07-25

Okay I had to add the CatfishSettings.py file to Makefile.in.in

Best Sean Davis (bluesabre) said : #2

Yeah, I had missed that, but it should be fixed in the latest commits.

Thanks, but I don't see it currently (or did you mean it's going to be done in the next commit?)
http://bazaar.launchpad.net/~catfish-search/catfish-search/trunk/view/head:/Makefile.in.in

Thanks Sean Davis, that solved my question.