Please help with Docky helper

Asked by FokkerCharlie on 2010-11-28

I recently installed Cardapio as a potential replacement for my main menu, and attached to the panel, it works well. However, I also installed the 'cardapio-docky- package from the unstable ppa, in the hope of getting it to work with Docky.

Unfortunately, this hasn't worked out. I open Docky settings, and there is no Cardapio helper in the list. I can get other helpers / docklets to work just fine.

Have I missed something? Or should I file a bug?

Thanks in advance.
Charlie

Question information

Language:
English Edit question
Status:
Solved
For:
Cardapio Edit question
Assignee:
No assignee Edit question
Solved by:
FokkerCharlie
Solved:
2010-11-28
Last query:
2010-11-28
Last reply:
2010-11-28
Paweł Bara (keirangtp) said : #1

Run this command from a terminal: "ls /usr/share/dockmanager/scripts/". Do you see a cardapio_helper.py here? Are there more .py files in the folder?

Also, in Docky's settings, go to the Helpers tab and change the selection from "Usable" to "All" there. Do you see Cardapio's helper now?

Hi Pawel

Thanks for your response, and your excellent work with cardapio.

I see cardapio_helper.py in the scripts folder you mention, and no other files in there.

I've had a rummage around, and it looks like the other helpers are in /usr/share/docky/helpers. So I copied the cardapio_helper.py file to that folder, and I can now see it in the 'Helpers' list. I can enable it, but it doesn't seem to have any effect.

Incidentally, I don't have a 'useable' option for the helpers, only 'All', 'Enabled' and 'Disabled'.

Any other thoughts?

Charlie

OK, I don't know if this is any help to you (or me!), but a bit of terminal output:

$ docky --debug | grep cardapio
[Info 03:17:00.778] [Helper] Starting cardapio_helper.py
[Info 03:17:00.794] [HelperService] Helper added: /usr/share/docky/helpers/cardapio_helper.py
[Info 03:17:00.809] [Helper] cardapio_helper.py has exited (Code 0).

Charlie

Paweł Bara (keirangtp) said : #4

What Docky's version are you using? You can check it by right clicking the anchor icon, and there's the "About program" option.

I'm beginning to think that you are using a very old version, when there were no DockManager yet and the 'Useable' option was not present yet.

Paweł Bara (keirangtp) said : #5

Also, please run this from the terminal: "gconftool -g /apps/docky-2/Docky/Items/DockyItem/DockyItemCommand" and paste here your output.

I have been running ver 2.0.7 from the Ubuntu repos.

Upgrading using the docky ppa to ver 2.1.0 fixed the issue.

Many thanks again.

Charlie

Paweł Bara (keirangtp) said : #7

No problem! I updated the FAQ about installing Docky's integration. It now describes the new way of doing things (helper and not the old "show-near-mouse" hack). Also, it mentions that you need the latest Docky to be able to use the integration. :)