Use super key as hotkey

Asked by foxnbk on 2010-08-18

Hey,

i wonder if it's possible to use only the super key as the hotkey (Windows-style). Enter <Super> in the hotkey field doesn't work :( Any ideas?

Question information

Language:
English Edit question
Status:
Solved
For:
Cardapio Edit question
Assignee:
No assignee Edit question
Solved by:
foxnbk
Solved:
2010-08-21
Last query:
2010-08-21
Last reply:
2010-08-19
Thiago Teixeira (tvst) said : #1

I believe this is a Gnome issue. It used to be that if you went to

Keyboard Preferences > Layouts > Options

and played with the settings for "Alt/Win key behavior", you'd eventually find a setting that worked as you wish. However, I can't seem to accomplish this on my Gnome 2.30.

So I'd recommend you look at Gnome bugs and forum posts for the solution. And if you find it, please post here :)

Sorry I can't be of any help.

foxnbk (foxnbk) said : #2

Yeah, just did some internet research and figured out that entering Super_L in the hotkey field works perfect!

Thanks foxnbk!

Thiago, I think we should make that the default then.

Thiago Teixeira (tvst) said : #4

The problem with making it default is that it breaks all other Super-key shortcuts that you may have assigned.

For example:

1) Open Gnome's Keyboard Shortcuts tool
2) Change the "Home folder" shortcut to Super+H
3) Test it out: press Super+H and the home folder appears. Great.

4) Go to Cardapio's Preferences window and make Cardapio's shortcut be Super_L
5) Test is out: press Super and Cardapio opens. Great.

* BUT *
6) Re-test #3 above: press Super+H and you *do not* get the home folder. Cardapio opens instead.

I consider this a Gnome bug, but I'm not sure if it has been reported before. If Gnome ever changes this behavior, then I will gladly switch the default shortcut to Super_L .

Reading through bug #54024, we should really make it default because it is easier for anyone advanced enough to have set up Super-modifier shortcuts to change the Cardapio shortcut than it is for anyone else to press Super+space every time (let alone change the shortcut).

See my related branch: https://code.launchpad.net/~jancborchardt/cardapio/various-fixes

Elisée Maurer (elisee) said : #6

Would it be possible to bind the shortcut to "key up" events instead of "key press" events? This might fix the issue with other shortcuts (like <Super>d) being broken when assigning Super_L as a shortcut for Cardapio. It would also avoid having the menu appearing & disappearing repeatedly when holding down the shortcut, because of key repeats.