How to use Cardapio with keyboard?

Asked by Jesús Pérez on 2010-06-30

Hello, I don't know if is a question or a "bug", but (sometimes) I want use Cardapio without mouse, like a (App) launcher only with the keyboard.

My problem is: I press <Super>space and then write something. All ok, I can see various "items", but I can't look into the "items" with the keyboard and I have to use the mouse to select the one that I want. There is any way to search and look only with the keyboard?

Un saludo.

Question information

Language:
English Edit question
Status:
Solved
For:
Cardapio Edit question
Assignee:
No assignee Edit question
Solved by:
Thiago Teixeira
Solved:
2010-07-01
Last query:
2010-07-01
Last reply:
2010-06-30
Best Thiago Teixeira (tvst) said : #1

Ok, here's how Cardapio's typical keyboard-only usage works:

1) Press Super+Space to show Cardapio
2) Type a search query

  a) If the top result is what you were looking for
     3) just press Enter -- this will launch the top result

  b) If the top result is *not* what you were looking for:
     3) Press Tab to select the results pane
     4) Use the arrow keys
     5) Press Enter on the result you want to launch

  c) If no results are useful
     3) Press Esc to clear the search query
     4) go back to step (2)

To hide Cardapio, press Esc again (or Super+Space)

Thiago Teixeira (tvst) said : #2

tvst suggests this article as an answer to your question:

I just created a FAQ about this question. Thanks for posting it!
FAQ #1190: “How do I use Cardapio with only the keyboard?”.

Jesús Pérez (tx2z) said : #3

Thanks tvst, that solved my question.

Jesús Pérez (tx2z) said : #4

I think there is a bug use cardapio with elementary theme (it's an elementary bug because in "Ambience" works ok). I can use the keyboard like you said, but I can't see in what item the focus is.... :(

Anyway. Thanks a lot :)

Un saludo.

Thiago Teixeira (tvst) said : #5

Wow, it seems that Elementary does not show the focus rectangle on *any* button in *any* application. You should try filing a bug with them, as this is quite bad for usability and accessibility.

Hello, and thank you for this great tool!
I'm using the version 0.9.186 and when I press enter nothing happens. I have to use the mouse. Is there a workaround for this?
I'm using Ubuntu 11.04 86_64.
Best regards.

Thiago Teixeira (tvst) said : #7

Hi André,

Thanks for posting this. I think the issue you're reporting has been fixed in the latest version of Cardapio, which will go into the PPA later today.

In the future, though, please open a bug report when you find something like this :)

Cheers,

- T

Ok. Thank you very much. For some strange reason I didn't thought this was a bug. ;-)