Unable to log in with Firefox

Asked by Thomas Eschenbacher

Trying to log in to https://login.launchpad.net always fails with Firefox (16.0.1) and throws me back to the login page, without any reasonable explanation what goes wrong. It always shows this message, which is pretty useless for any user:

Your page was stale.

Apologies, the page you came from was a little old. Perhaps you navigated here from a browser window other than the one you used to login. If so, try using the other browser window. Or, try your action again, starting from our home page.
Go to our home page

Login with Konqueror (KDE-4.x) succeeds.

Question information

English Edit question
Canonical SSO provider Edit question
No assignee Edit question
Solved by:
Thomas Eschenbacher
Last query:
Last reply:
Revision history for this message
Ricardo Kirkner (ricardokirkner) said :

Hi Thomas,

this does look like an issue with your Firefox instance. Could you try to:

1. log out of https://login.launchpad.net, as well as https://launchpad.net
2. clean any cookies related to those sites from your browser
3. log in again

or alternative, start up 'Private Browser Mode', which will ensure 1. and 2. for you?

This way we can rule out any cookie-related issues with your browser.


Revision history for this message
Thomas Eschenbacher (thomas-eschenbacher) said :

Tried all of it, including Private Browsing Mode, but with no luck, sorry.

Then I tried starting Firefox in "safe mode", with all addons disabled - still the same.

Next I tried a different user account, which has lots of addons enabled, like AdBlockPlus, BetterPrivacy and so on - and that one worked!? - but Firefox under my own user account, even with all plugins/addons disabled, in safe mode, does not.

Any idea what else I could check?

Revision history for this message
Thomas Eschenbacher (thomas-eschenbacher) said :

just one thing, maybe it is unrelated, but...
this comes out on the Firefox "Error console" when I try to log in:

Timestamp: 31.10.2012 08:06:33
Warning: Unknown pseudo-class or pseudo-element '-webkit-file-upload-button'. Ruleset ignored due to bad selector.
Source File: https://login.launchpad.net/assets/identityprovider/launchpad/styles.css
Line: 58

Revision history for this message
Ricardo Kirkner (ricardokirkner) said :

Thomas... sorry to hear that. I will forward your request to a support agent (Selene Scriven). She will hopefully be able to get your account working again. As you can login using a different browser, I suspect this is a local Firefox issue. Just to give you some extra context, the 'stale page' error you got is usually caused by your browser not sending the right cookie back to the server, or due to some improper caching happening between the server and your browser.

Revision history for this message
Thomas Eschenbacher (thomas-eschenbacher) said :

Hi Selene, hi Ricardo,

I managed to solve the problem.
In my prefs.js there was the following setting:

user_pref("network.http.sendRefererHeader", 0);

This did not produce any problem with any website in the last few years, but made launchpad.net fail.
I switched the value from 0 to 1:

user_pref("network.http.sendRefererHeader", 1);

and now login works :-)

thanks a lot,