mumble username problem

Asked by Matt Waddel on 2010-05-20

I'm trying to setup mumble with the instructions that were emailed yesterday:
"Mumble now using Ubuntu SSO and available to all Canonical staff"

Everything sets up correctly and it appears to work, but after I connect
mumble displays an "interesting" username for me:
   Matt Waddel(markskilbeck-deactivated).

I would prefer a much more traditional display name like Matt Waddel(mwaddel).
I have no idea where "markskilbeck-deactivated" is coming from. As I understand
it, this information comes from launchpad and is part of my user profile, but I
could be mistaken. Can you shed any light on the problem?

Thanks,
Matt Waddel

Question information

Language:
English Edit question
Status:
Solved
For:
Canonical SSO provider Edit question
Assignee:
No assignee Edit question
Solved by:
Matt Waddel
Solved:
2011-02-16
Last query:
2011-02-16
Last reply:
2010-12-10
Whiteboard:
As far as we know in Launchpad, we have updated the necessary tables, but the problem in Mumble persists. Is this a replication problem in SSO or in Mumble?
Curtis Hovey (sinzui) said : #1

This issue sounds like the email address used to login was once associated with a merged acount. That account still hase and openid field so it is used instead of the master account.

Curtis Hovey (sinzui) said : #2

I have seen something like this happen on Launchpad once. We decided to mutate the merged account's openid to prevent it from being used. There is a script in the launchpad tree that can fix historic accounts. maybe it can be adapted to SSO.

    database/schema/pending/update-merged-person-accounts.sql

We currently obtain the username from a table replicated from launchpad's database and the matching is also done on a similar table so I'm not sure that we can do anything to fix this in the SSO DB itself.

Matt Waddel (mwaddel) said : #4

So this is a bug in the launchpad database? Do I need to log a bug somewhere else?

No. I've contacted the launchpad guys and they'll re-claim this question once they've confirmed it's something which needs fixing on their side.

Curtis Hovey (sinzui) said : #6

If the user name is wrong, that implies my orginal assumption that the user has two openids is correct. The script I suggested above database/schema/pending/update-merged-person-accounts.sql may fix this issue.

Stuart Bishop (stub) said : #7

Is there a bug open on this? person_merge needs to cope or the SSO needs to detect the merge form the lp_person record

Stuart Bishop (stub) said : #8

Curtis' script looks fine and I hae fixed the current data

Curtis Hovey (sinzui) said : #9

Yes bug 575317, The code is fixed on edge. The script fixes the historic data to work with the account split.

Matt Waddel (mwaddel) said : #10

So this problem is fixed on edge, but not the main launchpad database yet?

I just tried running mumble again and it still has the same problem. I did run
mumble from the command line and noticed in the start-up messages it says
this about my "UserState":

UserState:
session: 521
name: "Matt Waddel (markskilbeck-deactivatedaccount)"
user_id: 1000000113
channel_id: 18
comment: "mattman"

Gary Poster (gary) said : #11

Hm. Edge uses the main Launchpad database, so no, that's not the problem.

Perhaps it needs to be replicated still to the SSO DB? I'll pass this to Stuart Metcalfe in the hopes that he might know.

It's possible that the mumble plugin is caching the original username - I'd need to get someone to take a look at how the code handles subsequent logins. I'm afraid that's unlikely to happen this week.

Curtis Hovey (sinzui) said : #13

On Tue, 2010-05-25 at 15:10 +0000, Matt Waddel wrote:
> Question #111745 on Launchpad Foundations changed:
> https://answers.edge.launchpad.net/launchpad-foundations/+question/111745
>
> Status: Answered => Open
>
> Matt Waddel is still having a problem:
> So this problem is fixed on edge, but not the main launchpad database
> yet?

Edge is the main database.

> I just tried running mumble again and it still has the same problem. I did run
> mumble from the command line and noticed in the start-up messages it says
> this about my "UserState":

--
__Curtis C. Hovey_________
http://launchpad.net/

Matt Waddel (mwaddel) said : #14

Another new employee, that started about the same time I did, has
this same problem. His username shows up as a string of random
characters, that almost look like an automatically generated password.

That sounds like the generated unique identifier which would be returned if no matching launchpad username is found. Please provide details of the other new employee (launchpad username, ideally) so we can investigate both cases. Thanks

Matt Waddel (mwaddel) said : #16

His name is John Rigby. His name shows up as John Rigby (zpXbypE)

Matt Waddel (mwaddel) said : #17

This problem still exists with my account. Kiko pointed out
this morning that there actually is a launchpad account
called "markskilbeck-deactivatedaccount". Any ideas how
this is bleeding over into my username?

https://launchpad.net/~markskilbeck-deactivatedaccount

Should this be logged as an official bug? It seems to be
affecting all new starters. Kate Stewart is seeing this
problem - https://launchpad.net/~kate.stewart

Elliot Murphy (statik) said : #18

Yes, this should be logged as an official bug and given a high priority.

Julien Funk (jaboing) said : #20

Update -There has been a fix posted for this defect, it should be tested and released with the next SSO cycle.

Matt Waddel (mwaddel) said : #21

This problem is fixed now. Thanks.