Why can't I log in with my Launchpad credentials?

Asked by Dylan McCall


At login.ubuntu.com, the following text is above the login form:
“Please note that if you've registered with Launchpad you can use your existing Launchpad credentials to log in.”

However, I tried logging in with my email (as used for Launchpad) and my Launchpad password and the form replies that my password didn't match.

Is this feature not implemented yet, or is something weird with my account?

Thanks for any help :)

Question information

English Edit question
Canonical SSO provider Edit question
No assignee Edit question
Solved by:
Dylan McCall
Last query:
Last reply:
Revision history for this message
Stuart Metcalfe (stuartmetcalfe) said :

Hi. Credential sharing is implemented - we actually share the same database so it's more of a necessity than a feature right now. If you're having problems then it may mean that you've discovered a bug. Can you temporarily change your password in Launchpad to something with only ascii letters and numbers, log out and in again to confirm it works and then try logging in to login.u.c? If that works, change your password back to the original in login.u.c and see if it then works in Launchpad. If not, and if you have time, could you change 1 character at a time until you identify all those that don't work and let us know what they are?


Revision history for this message
Dylan McCall (dylanmccall) said :

Hi Stuart!

Thanks for your help. Turns out the email part is case sensitive, so I entered it as I have my email set in Launchpad and it worked.

Revision history for this message
Stuart Metcalfe (stuartmetcalfe) said :

Glad you were able to figure it out. Perfect timing btw ... the fix for that particular bug is due to land on our production server tomorrow!