Some features don't work on ubuntu, like "jet" definition

Asked by Ali Rajabi

I have installed calchep on my ubuntu machine. there are some differences between the one I use on my system and the tutorial. One of the main issues I have is that when I enter a process and define 5 light quarks plus gluon as jet, and I try to set a cut or distribution, for example the transverse momentum of the "jet" be in some range, or even when I want to define it as a distribution to plot it finally, I keep getting an error that "jet" is not defined. It is explicitly mentioned on the help page.

The problem is that it needs the cuts set according to the sub-process, not doing it for the general case. What I like to do is to apply the cut, and set the distributions, and in the command prompt run ../bin/subproc_cycle 0 0 so it runs over all sub-processes and I can plot the summed distribution finally.

There is an issue on running ../bin/subproc_cycle 0 0, which is I have to run the integration on the first two sub-processes at least so the command would work.

I appreciate any help you can offer.


Question information

English Edit question
CalcHEP Edit question
No assignee Edit question
Last query:
Last reply:

This question was reopened

Revision history for this message
Neil Christensen (neil-christensen-qft) said :

Dear Ali,

What version of CH are you using? What exactly do you type in the "Alias" table? What do you type in the cuts or distribution table?


Revision history for this message
Ali Rajabi (arajabi) said :

Dear Neil,

 Thank you so much for your prompt response.
Well I am using the latest version (3.4). I think my mistake was that I didn't type anything in the Alias table, but after you mentioned, I defined jet in the Alias table and it worked.
I type :

Parameter Min value Max Value
T(Jet) 5 15

on the distribution table and it used to give me error, which is resolved now.

By the way, do you have any suggestion for the second issue I have, running subproc_cycle from the bash without running a few subprocess by hand?


Revision history for this message
Ali Rajabi (arajabi) said :

Dear Neil,

I ran into another problem. It doesn't store the statistics from previous subprocess, and it says that because some parameters are changed, the previous distributions are forgotten. Is there a way to solve this?


Revision history for this message
Neil Christensen (neil-christensen-qft) said :

It sounds like you might like the batch interface. See Section 7 of:


Revision history for this message
Alexander Pukhov (pukhov) said :

"distributions are forgotten"
Indeed they are saved in file distr_# .
There are tools show_distr and sum_distr. See CalcHEP/bin/README for details.
Other way is to use batch, as Neil has proposed

Can you help with this problem?

Provide an answer of your own, or ask Ali Rajabi for more information if necessary.

To post a message you must log in.