SARAH model implementation into CalcHEP

Asked by Daniel William Busbridge

Hi there!

I've been having some issue importing a model created in SARAH into CalcHEP. The CalcHEP model was created in SARAH with the options of then forcing CalcHEP to read the numerical information from a SLHA file.

After importing the model, I find an issue at the end of every line in 'Parameters, Constraints, Particles and Vertices.' There is a symbol that looks similar to a 'line return,' symbol, although it is not present when opening the relevant document in e.g. gedit.

Here is a screenshot of the Constraints document as seen from CalcHEP

When I press 'Check Model,' I receive the error:

"Error in table 'Contraints <line return symbol>' line 1 field 'Expresssion' position 30: Operation expected"



Question information

English Edit question
CalcHEP Edit question
No assignee Edit question
Solved by:
Neil Christensen
Last query:
Last reply:
Revision history for this message
Best Neil Christensen (neil-christensen-qft) said :

Hi Daniel,

It may be that it has DOS new line characters at the end. If this is the case, you can convert the file to UNIX new line characters with the command:

tr -d '\r' < input > output

Please try this and let us know if it works.

Best wishes,

Revision history for this message
Daniel William Busbridge (d-w-busbridge) said :

Thanks Neil Christensen, that solved my question.