Missing themes and icons, AND no plugins are working?

Asked by Chris Banakis on 2012-05-28

I am so confused about this. (Maybe just a bug?)

I just did a clean install of Ubuntu 12.04, and Cairo Dock.

Fo some reason, Cairo seems to be having all sorts of trouble.

I can't install applets via drag and drop from the website.

Applets that need a web connection behave as though they have no internet available.
(ie weather applet wont search for location)

Lots of missing themes, and icons.
(only 2 cairo themes available, and every applet only has 1 icon to choose from)

I've installed cairo before without any issues, so I dont think I am doing anything wrong, but who knows for sure.

I really want to get this working, so any suggestions will be appreciated.

Thanks

I have also started this thread on Ubuntu forums.
http://ubuntuforums.org/showthread.php?p=11975980#post11975980

Question information

Language:
English Edit question
Status:
Solved
For:
Cairo-Dock Plug-ins Edit question
Assignee:
No assignee Edit question
Solved by:
Chris Banakis
Solved:
2012-05-29
Last query:
2012-05-29
Last reply:
2012-05-28

This question was reopened

Chris Banakis (cbanakis) said : #1

It seems like the problem is that Cairo doesn't seem to have access to the internet, in some weird sorta way?

Matthieu Baerts (matttbe) said : #2

> It seems like the problem is that Cairo doesn't seem to have access to the internet
Yes, I guess you're right.

Are you using a proxy?
Can you open the configuration panel of the dock / Advanced mode / System module / Internet Connexion. Is it better if you force the use of IPv4 (or if you disable this option)?

If you still have a problem, can you launch the dock from a terminal with this command and post all new messages you'll have when you drop a new applet into the dock?
    $ cairo-dock -l debug

Chris Banakis (cbanakis) said : #3

Not using a proxy.

Messing with the timeout settings, and forcing IPv4 on or off seems to have no effect.

This is what I get from terminal, just from running Cairo from command line.

warning : (/build/buildd/cairo-dock-3.0.1/src/gldit/cairo-dock-opengl.c:cairo_dock_initialize_opengl_backend:209)
  couldn't find an appropriate visual, trying to get one without Stencil buffer
(it may cause some little deterioration in the rendering) ...

 ============================================================================
 Cairo-Dock version : 3.0.1
 Compiled date : May 20 2012 16:26:00
 Built with GTK : 3.4
 Running with OpenGL: 1
 ============================================================================

CairoKeyBinding '<Super>L' failed!
warning : (/build/buildd/cairo-dock-3.0.1/src/gldit/cairo-dock-keybinder.c:cd_keybinder_bind:283)
  Couldn't bind '<Super>L' (Log out: Lock the screen)
 This shortkey is probably already used by another applet or another application
_cd_find_volume_name_from_drive_name: assertion `pDrive != NULL' failed
CairoKeyBinding '<Super>Return' failed!
warning : (/build/buildd/cairo-dock-3.0.1/src/gldit/cairo-dock-keybinder.c:cd_keybinder_bind:283)
  Couldn't bind '<Super>Return' (Control from keyboard: Enable/disable the keyboard control of the dock)
 This shortkey is probably already used by another applet or another application
warning : (/build/buildd/cairo-dock-plug-ins-3.0.1/quick-browser/src/applet-config.c:read_conf_file:70)
  Quick Browser : this path ((null)) is not a valid folder
 We'll use the 'home' instead.
warning : (/build/buildd/cairo-dock-3.0.1/src/gldit/cairo-dock-packages.c:cairo_dock_get_url_data_with_post:350)
  an error occured while downloading 'http://xml.weather.com/weather/local/FRXX0076?cc=*&unit=m' : Timeout was reached
warning : (/build/buildd/cairo-dock-3.0.1/src/gldit/cairo-dock-packages.c:cairo_dock_get_url_data_with_post:350)
  an error occured while downloading 'http://xml.weather.com/weather/local/FRXX0076?cc=*&unit=m' : Timeout was reached

Chris Banakis (cbanakis) said : #4

This is what I get when I try to add an applet...

warning : (/build/buildd/cairo-dock-3.0.1/src/gldit/cairo-dock-packages.c:cairo_dock_download_file:178)
  an error occured while downloading 'http://download.tuxfamily.org/glxdock/mediacolor/album8/1333390141_f0634cf366/Twitter.tar.gz'

Matthieu Baerts (matttbe) said : #5

Strange...
Can you launch these commands from a terminal and post the output messages?

    $ curl http://download.tuxfamily.org/glxdock/mediacolor/album8/1333390141_f0634cf366/Twitter.tar.gz -O && rm Twitter.tar.gz
    $ curl -4 http://download.tuxfamily.org/glxdock/mediacolor/album8/1333390141_f0634cf366/Twitter.tar.gz -O && rm Twitter.tar.gz
    $ curl -6 http://download.tuxfamily.org/glxdock/mediacolor/album8/1333390141_f0634cf366/Twitter.tar.gz -O && rm Twitter.tar.gz

Chris Banakis (cbanakis) said : #6

curl http://download.tuxfamily.org/glxdock/mediacolor/album8/1333390141_f0634cf366/Twitter.tar.gz -O && rm Twitter.tar.gz
  % Total % Received % Xferd Average Speed Time Time Time Current
                                 Dload Upload Total Spent Left Speed
100 382k 100 382k 0 0 18221 0 0:00:21 0:00:21 --:--:-- 451k

curl -4 http://download.tuxfamily.org/glxdock/mediacolor/album8/1333390141_f0634cf366/Twitter.tar.gz -O && rm Twitter.tar.gz
  % Total % Received % Xferd Average Speed Time Time Time Current
                                 Dload Upload Total Spent Left Speed
100 382k 100 382k 0 0 281k 0 0:00:01 0:00:01 --:--:-- 476k

curl -6 http://download.tuxfamily.org/glxdock/mediacolor/album8/1333390141_f0634cf366/Twitter.tar.gz -O && rm Twitter.tar.gz
curl: (6) Couldn't resolve host 'download.tuxfamily.org'

Chris Banakis (cbanakis) said : #7

I assume curl -4 is testing using IPv4?

that one gave output much faster.

Thank you very much for your help with this.

Could it have anything to do with my router settings?

Strange how internet/ubuntu updates/software center all work fine.

but for some reason Cairo does not seem to see the internet

Chris Banakis (cbanakis) said : #8

I assume curl -4 is testing using IPv4?

that one gave output much faster.

Thank you very much for your help with this.

Could it have anything to do with my router settings?

Strange how internet/ubuntu updates/software center all work fine.

but for some reason Cairo does not seem to see the internet

Matthieu Baerts (matttbe) said : #9

> Strange how internet/ubuntu updates/software center all work fine.
Yes it's strange but Cairo-Dock doesn't use the same servers ;)

> I assume curl -4 is testing using IPv4?
Yes so I guess you've to enable this option: "Force IPv4?"
Without that it seems it takes more than 20sec to connect to our server.
Note that you can also increase the connection timeout, maybe it can help.

Chris Banakis (cbanakis) said : #10

Yeah, I tried all that.

this makes no sense to me, but I am no expert.

Chris Banakis (cbanakis) said : #11

Ah Ha (Sortof)

Based on a gut feeling, I plugged my computer dirrectly into my modem, bypassing my router, and VUALA!!!

So, this begs the question, what about my router is getting in the way?

Its a pretty high-tech router, so whatever setting is in the way, I'm sure I can change it.

The problem is that it may be a little too high-tech. (Way to complicated for me)

Its a dual WAN load ballancer.

My friend set it up for me years ago. :(

Matthieu Baerts (matttbe) said : #12

Maybe you can add these 4 lines at the end of this file: /etc/sysctl.conf (you have to edit it with root right, e.g.: sudo gedit /etc/sysctl.conf )

#disable ipv6
net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1

And then restart sysctl with this command: sudo sysctl -p

If it's not better, remove these 4 lines from the sysctl.conf file.

Chris Banakis (cbanakis) said : #13

No change.

Any guess on a port number or something that cairo uses, that I can try to un-block in my router?

I really have no idea what I am doing when it comes to this router, but if I at least know what I need to do, I might be able to figure it out.

hopefully...

Matthieu Baerts (matttbe) said : #14

> No change
Even when you launch this command?
    $ curl http://download.tuxfamily.org/glxdock/mediacolor/album8/1333390141_f0634cf366/Twitter.tar.gz -O && rm Twitter.tar.gz

(if you still have the same problem, restart your computer, just to be sure that sysctl and other things have been restarted correctly ;) )
If it still takes to much time to connect, I guess the problem is somewhere else.

> Any guess on a port number or something that cairo uses, that I can try to un-block in my router?
No, it uses the port 80 to connect to our server.
Did you try to simply restart your router?

Chris Banakis (cbanakis) said : #15

Seems the same...

curl http://download.tuxfamily.org/glxdock/mediacolor/album8/1333390141_f0634cf366/Twitter.tar.gz -O && rm Twitter.tar.gz
  % Total % Received % Xferd Average Speed Time Time Time Current
                                 Dload Upload Total Spent Left Speed
100 382k 100 382k 0 0 18264 0 0:00:21 0:00:21 --:--:-- 300k

Tried restarting the modem, router, and computer too.

Matthieu Baerts (matttbe) said : #16

It seems this problem is known: http://google.com/?q=slow+connexion+ubuntu+12.04
Maybe you can try with another DNS server: e.g. 8.8.8.8 (edit you connexion and set this address for the DNS)

Chris Banakis (cbanakis) said : #17

Doesn't seem to help.

Why don't you think the router is the problem?

If it works without the router, that makes me feel that the router is the problem?

Matthieu Baerts (matttbe) said : #18

Yes I guess that the router is the problem but it's a bit strange.
Is it maybe possible to disable IPv6 (or force IPv4) on your router?

As workaround you can edit this file: ~/.config/cairo-dock/current_theme/cairo-dock.conf
 and modify this line: conn timeout=X
 replace X by 60 in order to have a timeout of 60 seconds.

PS: if you click on this link on your browser, do you have the same problem? http://download.tuxfamily.org/glxdock/mediacolor/album8/1333390141_f0634cf366/Twitter.tar.gz

Chris Banakis (cbanakis) said : #19

I don't think I can disable IPv6 in my router.

I'll have to try the other stuff when I get back home later.

I already tried downloading the applets instead of dragging the link, and that works fine.

Chris Banakis (cbanakis) said : #20

Changing the timout to 60 seconds seems to get everything working.

Not sure what in the router is creating all the lagg.

Hopefully I can figure that out soon though.

Thank you very much for you help with this.
I was about to lose my mind.

Please let me know if you think of a more permanent solution, as I am continuing to try to make it work the right way.

Thank you again.

Now I can finally start using Cairo Dock again!!!

Chris Banakis (cbanakis) said : #21

Looks like I spoke to soon.

It did work for a moment, but then nothing.

Thats still progress though.
(We got it to work without bypasssing the router this time)

There has got to be a setting somewhere in this router that will fix this.
Unfortunately, networking is an area I have very little experience with. :(

Chris Banakis (cbanakis) said : #22

If your up for it, I did figure out how to allow remote access to my router setup.
If you feel up to poking around in there.

I would prefer to send you a private message with the login info though, instead of publicly posting my ip, and router user name and password.

Chris Banakis (cbanakis) said : #23

Well, I found another "Simpler" router laying around, and switched it out.

I had the advanced router, because it had dual wan ports, and load balancing.

At the time, I had a room mate, and we had 2 isp's on our network.

But now Its just me and the wife, and a single isp.

So I don't really need to use the better router.

Put the cheapo router in, and BAM! everything works like a charm.

At some point, I am interested in figureing out what the option is that was inhibbiting Cairo Dock, but in the mean time, I am sinply going to NOT use that router anymore.

Who would have thought that my $300 enterprise level router would cause a problem, that would be solved with a $20 netgear router I bought at best buy 8 years ago. LOL

Thanks again for everything.

This one is solved.