Verbose push/pull and tags

Asked by Javier Collado on 2009-05-18

Hello,

When pushing a branch in which no new revision has been added, but a new tag has been created, the output to the command, even using the verbose flag, is:
No new revisions to push.
Nothing seems to have changed

On the other hand when pulling in a branch for which a new tag has been added, the output is (also using the verbose flag):
No revisions to pull.

Hence, in both cases the behaviour is as if nothing has been updated; however, it can be verified that the tag information is indeed being updated so my question is:
Why push/pull --verbose don't display any information about tags?

Best regards,
   Javier

Question information

Language:
English Edit question
Status:
Solved
For:
Bazaar Edit question
Assignee:
No assignee Edit question
Solved by:
Martin Pool
Solved:
2009-06-04
Last query:
2009-06-04
Last reply:
2009-06-04
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Hello,

Before letting this question go away, I just want to summarize it briefly to make sure that the explanation was clear. The problem is that tags are pushed/pulled under the hood and I think that it would be valuable to display some information about this at least when verbose mode is used. Do you agree?

Best regards,
    Javier

Matt Nordhoff (mnordhoff) said : #3

Sure, I agree.

I'm sure a good patch would be accepted if somebody sent one. It's just that nobody has cared enough to do it.

Best Martin Pool (mbp) said : #4

Yes, I agree bzr should show a message. See bug 164450.

Thanks Martin Pool, that solved my question.