Is a semi-mature autocompletion available in “bzr shell”?

Asked by Zearin

PRELIMINARY NOTE (Some quick background info about me) :

I'm relatively new to version control. Briefly tried SVN for personal projects, and found that I hated network requirements and file locks with the fire of a thousand suns. Bazaar's flexibility was intimidating at first (with so many different workflows, which should I use?), but I'm finally starting to warm up to it and use it for personal projects.

I use the “bzr shell” exclusively. (See .)

It's a great feature, saving me lots of time by not having to type “bzr” in front of every command. If I understand correctly, it even performs better under the hood, too.

My only gripe with it is having to type out entire paths. No autocompletion for commands is a little annoying too—but most commands are relatively short, and paths (or URLs) are potentially quite long.

I checked the Bazaar plugins page and found the plugin “bzr-bash-completion”:
 • (BzrPlugins page listing it)
 • (branch containing the plugin)

However, it contains no instructions on how to use it, or even whether it works as simply as most other plugins (branch a plugin into ~/.bazaar/plugins/). And the README says it's “crude” and “incomplete”.

While “incomplete” is less than ideal, I can't seem to find a way to get ANY autocompletion inside “bzr shell”. :(

Is there a way to achieve autocompletion inside “bzr shell”?
If not, is there any work being done on this?


Question information

English Edit question
Bazaar Edit question
No assignee Edit question
Solved by:
Martin Pool
Last query:
Last reply:
Revision history for this message
Martin Pool (mbp) said :


bzr bash completion is not relevant at all to bzr shell, only to the bash shell.

For me, the current version of bzr shell (from does seem to have working autocompletion: if I start it with 'bzr shell' and type 'ls <tab>' then I get a list of possible options and filenames. I'm testing on Ubuntu. What happens for you?

Revision history for this message
Zearin (zearin) said :


For me, if I type 'bzr shell' and then 'ls <tab>', it inserts a tab character on the command line. :)

I'm using Mac OS X 10.5.7 (Leopard) and the latest version of Bazaar (1.14.1).

Revision history for this message
Best Martin Pool (mbp) said :

That seems to be a bug 376742 in bzrtools; thanks for reporting it and let's take the conversation over there.

Revision history for this message
Zearin (zearin) said :

Thanks Martin Pool, that solved my question.