Unable to commit release branch

Asked by Ross Light

With my 0.2 release branch of my progtools project (located at ~quartz25/progtools/release-0.2), I am unable to commit any new revisions. I deleted the branch and repushed it, but it continues to give me this error:

bzr: ERROR: Revision {set([('null:',)])} not present in "KnitVersionedFiles(_KnitGraphIndex(CombinedGraphIndex(GraphIndex('file:///home/ross/src/Python/Projects/progtools/.bzr/repository/indices/eb5b6af505e3e4e0aa5bf51290c94afa.iix'), GraphIndex('file:///home/ross/src/Python/Projects/progtools/.bzr/repository/indices/21098a6d85463cdd6ece4305f34b9479.iix'), GraphIndex('file:///home/ross/src/Python/Projects/progtools/.bzr/repository/indices/18a6c1f50eb47ba227fc7fc9a8a469b8.iix'), GraphIndex('file:///home/ross/src/Python/Projects/progtools/.bzr/repository/indices/1782561d38eac87b29fb8c135f3dddca.iix'), GraphIndex('file:///home/ross/src/Python/Projects/progtools/.bzr/repository/indices/107c4f625c5b89416f942dc32248aaed.iix'))), <bzrlib.knit._DirectPackAccess object at 0x885114c>)".

I ran "bzr check" and "bzr reconcile", but nothing appears to be wrong. Any thoughts?

Question information

English Edit question
Bazaar Edit question
No assignee Edit question
Solved by:
Martin Pool
Last query:
Last reply:
Revision history for this message
Andrew Bennetts (spiv) said :

This is probably a bzr bug, rather than a Launchpad issue.

What version of bzr are you using? What format is your local branch and repository in (i.e. what does "bzr info -v" report)? It's possible that you're hitting bug 291046.

Revision history for this message
Andrew Bennetts (spiv) said :

Also, if you could upload a tarball of your local repository+branch, that would be great. That way I might be able to reproduce the bug locally rather than pester you with endless requests for more information :)

Revision history for this message
Ross Light (quartz25) said :

I am using bzr 1.10 with Python 2.5 on Ubuntu Intrepid. Running "bzr info -v" gets me this output:

Repository tree (format: 1.6)
  shared repository: /home/ross/src/Python/Projects/progtools
  repository branch: .

Related branches:
  push branch: bzr+ssh://bazaar.launchpad.net/%7Equartz25/progtools/release-0.2/

       control: Meta directory format 1
  working tree: Working tree format 4
        branch: Branch format 7
    repository: Packs 5 (adds stacking support, requires bzr 1.6)

In the working tree:
        12 unchanged
         0 modified
         0 added
         0 removed
         0 renamed
         0 unknown
         0 ignored
         1 versioned subdirectory

Branch history:
        19 revisions
         1 committer
        12 days old
   first revision: Fri 2008-12-05 16:12:33 -0800
  latest revision: Wed 2008-12-17 16:44:51 -0800

        50 revisions

I have uploaded the repository here (answers should have attachments, but that's a different problem :D):

Revision history for this message
Launchpad Janitor (janitor) said :

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Revision history for this message
Ross Light (quartz25) said :

This problem is still affecting me, should I report a bug?

Revision history for this message
Best Martin Pool (mbp) said :

Yes, please do report a bug and if possible attach a tarball of the branch to it.

Revision history for this message
Ross Light (quartz25) said :

Thanks Martin Pool, that solved my question.