bzr push don't ask for password

Asked by VinsS on 2014-11-20

Yesterday, for my first push of the journey, bzr ask me my passphrase in graphical mode. That's never arrived in the past.

Ok, no problem with that but since this operation, bzr don't ask anymore for my password.

I use the push with :

vincent@djoliba:~/oqapy-2/oqapy$ bzr push
Using saved push location: bzr+ssh://

It's normal, new or other ? May I fill a bug report ?

Thanks for all advices.

Question information

English Edit question
Bazaar Edit question
No assignee Edit question
Solved by:
Vincent Ladeuil
Last query:
Last reply:
VinsS (vincent-vandevyvre) said : #1


I'm using trusty 14.04 with the desktop Mate.

Vincent Ladeuil (vila) said : #2

> bzr ask me my passphrase in graphical mode

Sounds like an graphical ssh agent to my ears.

> bzr don't ask anymore for my password.

Sounds like the ssh agent is doing its job of remembering which ssh key you used and avoid you the hassle of typing it endlessly.

So, what did "never happen in the past" ?

Being asked for the passphrase or being asked only once ?

In any case, bzr is not responsible for handling ssh keys access, it attempts to connect via ssh (you're pushing to launchpad with bzr+ssh) and ssh handles key access.

In summary, I'd say it's normal and desired ;)

So you may want to investigate how ssh is configured and whether something changed in this area.

VinsS (vincent-vandevyvre) said : #3

"never happen in the past" in graphical mode.

Since more than four years I'm using bzr, he ask me always my password for a push command and I think it's regular because it's a ssh connection.

But yesterday and today, no password is required (6 commits).

I've made no change in my config recently.

If you say me that's not a critical problem, it's ok for me.


Best Vincent Ladeuil (vila) said : #4

Try this from the terminal where you issued 'bzr push' without a password:

$ ssh-add -l

The ssh key you use for launchpad should be displayed.

$ ssh-add -D
All identities removed.

$ ssh-add -l
The agent has no identities.

$ bzr push

You're asked for your passphrase

$ ssh-add -l

Your key should be listed again.

VinsS (vincent-vandevyvre) said : #5

Thanks Vincent Ladeuil, that solved my question.