Mac OS bzr installation doesn't support latest Python 2.7

Asked by Alex Lomov on 2014-03-12

Not so long using launchpad.net, so I decided to create question neither bug report

I am mac os user (Mac OS X 10.9.2) and I have several versions of python (starting with 2.5 to 2.7). python binary was set to use 2.7.5 version.

I installed bzr with brew and it worked as I understand. After that I needed to remove brew version and to install it using install tools. After that bzr crashed with some sort of python error.

the only thing that helped me is described in this article http://instanceof.me/post/7880963425/fixing-bazaar-for-mac-os-x-10-7-lion : I needed to specify python version after hashbang in bzr binary.

Is it possible to add Python version check and warning message? Do you think I need to create issue for this kind of problem?

Question information

Language:
English Edit question
Status:
Solved
For:
Bazaar Edit question
Assignee:
No assignee Edit question
Solved by:
Alex Lomov
Solved:
2014-03-12
Last query:
2014-03-12
Last reply:
Alex Lomov (lomov-as) said : #1

I have found this discussion https://bugs.launchpad.net/bzr-mac-installers/+bug/731391, will discuss it there.