bzr error on push to Cloud Control

Asked by Maurice Mooij

I have tried the following commands to try push my website to Cloud Control

cctrlapp APPNAME push

In both cases this results in the following error.

bzr: ERROR: Tip change rejected:

Does anyone know what I can do about this?

Question information

English Edit question
Bazaar Edit question
No assignee Edit question
Solved by:
Maurice Mooij
Last query:
Last reply:
Revision history for this message
Maurice Mooij (maurice-mooij) said :

This is the final response from the Cloud Control support staff:

Alright I dug into this a little. What's happening here is, that the buildpack expects the webroot to be a subdirectory and it tries to autodetect that subdirectory. This setup with a subdirectory seems to be the default for Yii apps generated by the cmdline script as far as I can tell.

We currently do not seem to support index.php or .htaccess in the repository root for Yii apps. I opened a bug ticket on the php-buildpack to discuss if and how to support this aswell.

You can see the bugticket here:

For your immediate issue, I suggest to move the files that need to be accessible externally to a seperate webroot and try to resemble the same directory structure that the yii command line client generates.