Patching Bazaar Explorer

Asked by Arthur Mori on 2012-10-22

greetings,

i am really having a very difficult time with patching bazaar explorer, i am using a mac and i am having the "too many files" error as posted here: https://bugs.launchpad.net/bzr-explorer/+bug/926439 .... would it be possible if i could ask for some assistance, i am not much of a terminal guy, and most mxperience are gui dependent, so installation has always been automatic for me.... i've searched over the net on how to do this, but i was unable to find one....w/ch leads me to here. So i hope someone reads this and helps me out here, thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Bazaar Edit question
Assignee:
No assignee Edit question
Solved by:
Vincent Ladeuil
Solved:
2012-10-22
Last query:
2012-10-22
Last reply:
2012-10-22
Vincent Ladeuil (vila) said : #1

Your comment on bug #926439 seems to indicate you tried to apply the patch to a version different than the one it was meant to be applied.

I.e. make sure you're using the right version, Alexander said:

   Can you try this patch, please? Apply it to your copy of bzr-explorer 1.2.2

So, are you using 1.2.2 or something else ?

  bzr plugins -v

should tells you which versions of the plugins are used and where they are installed.

Arthur Mori (awsmori) said : #2

double checked my version and yes may explorer is running 1.2.2

Arthur Mori (awsmori) said : #3

i type in 'bzr patch workaround-926439.patch'

and it return an error

The text leading up to this was:
--------------------------
|=== modified file 'lib/filesystemwatcher.py'
|--- lib/filesystemwatcher.py 2012-02-21 06:40:23 +0000
|+++ lib/filesystemwatcher.py 2012-02-22 05:09:15 +0000
--------------------------
No file to patch. Skipping patch.
1 out of 1 hunk ignored
bzr: ERROR: Patch application failed

.....so i am not sure if i am patching it correctly, is "bzr patch workaround-926439.patch" correct?
...thanks for the reply btw

Best Vincent Ladeuil (vila) said : #4

Right, so if you have the right version for bzr-explorer, may be you're trying to apply this patch in the wrong directory.

'bzr plugins -v' will tell you were bzr-explorer is installed and that's where you should try to apply the patch.

i.e. 'No file to patch. Skipping patch.' means that 'lib/filesystemwatcher.py' is not found in the directory 'patch' is run.

Arthur Mori (awsmori) said : #5

Thanks Vincent Ladeuil, that solved my question.

Arthur Mori (awsmori) said : #6

i was doing the patching from my working directory, thinking that would be alright as long as bzr command exist.... thanks again vincent