Cant create a branch for calibre

Asked by David E Resnick on 2012-06-15

I have downloaded Bazaar and am trying to create a branch for calibre using the instructions in the calibre user manual
I am on windows xp. I enter the command shell.
I type:
 bzr branch lp:calibre
and I get the following:
Connected (version 2.0, client twisted)
bzr: ERROR: Connection error: Unable to authenticate to SSH Host as <email address hidden>
supported auth types ['publickey']

Kovid Goyal said to delete my identity from bazaar - How do I do that?

I tried launching bazaar gui and eliminating it yet that did not work either.

The alternate method of creating an ssh key just doesnt seem to work.

Thank you for your response

Question information

Language:
English Edit question
Status:
Solved
For:
Bazaar Edit question
Assignee:
No assignee Edit question
Solved by:
Martin Packman
Solved:
2012-06-19
Last query:
2012-06-19
Last reply:
2012-06-19
Best Martin Packman (gz) said : #1

You can run the following command to undo lp-login and go back to using read-only http access:

    bzr config --scope=bazaar --remove launchpad_username

If you need to write to a branch hosted on launchpad later though, you'll have to go through the ssh setup steps documented here:

<https://help.launchpad.net/YourAccount/CreatingAnSSHKeyPair>

(Which I see you've done some of, as you have an ssh key associated with your account now.)

David E Resnick (deandpcr) said : #2

Thank you. I managed to follow the instructions on puttygen to completion and then was able to do the necessary.