bzr: ERROR: Path(s) are not versioned: ???

Asked by Rob Burrowes on 2007-12-10

I'm trying bazaar for the first time and got the following error, which I don't understand.

rob1:ratlas2 rbur004$ bzr checkout bzr+ssh://<email address hidden>/~rob-burrowes/ratlas/trunk
rob1:ratlas2 rbur004$cd trunk/ruby_extension
...
Edit lots of files
...
rob1:ruby_extension rbur004$ bzr commit bzr+ssh://<email address hidden>/~rob-burrowes/ratlas/trunk
bzr: ERROR: Path(s) are not versioned: "ruby_extension/bzr+ssh:/<email address hidden>/~rob-burrowes/ratlas/trunk"

Using bzr diff gives a long list of file changes, so bzr knows the files have changed. What should I be doing that I'm not?

Question information

Language:
English Edit question
Status:
Solved
For:
Bazaar Edit question
Assignee:
No assignee Edit question
Solved by:
Rob Burrowes
Solved:
Last query:
Last reply:
Rob Burrowes (rob-burrowes) said : #1

Ok, stupid question. I should have used
bzr commit -m "Blah" .
to explicitly commit this directories changes and didn't have to specify the repository address.

Jon Loldrup (loldrup) said : #2

I had the same error, and also omitting the URL solved the problem (I had the -m "comment" on all the time).
But.. If this error really is about the user supplying the URL when it is not needed, then why do we get that error message? There must be a better explanation, or the error message is severely misguiding.

Marius Kruger (amanica) said : #3

@Jon The commit command takes a list of files/directories to commit,
so if you give it anything that is not files it knows about it will complain.
See `bzr commit --help` for more info.
Is it the custom for any other version control systems to supply a target repo as an argument to commit?

Vincent Ladeuil (vila) said : #4

To complete Marius answer: commit, by default, commit the changes for all the modified files.

But on certain occasions you want to do a partial commit, so you can specify which of the modified files or dirs you want to commit.

The url you give *is* a valid path so you could have a file with such a name, but if you provide a path that doesn't exist or does a typo in the path, it's hard to understand that you specified an url instead.

Especially when, like in the case reported here, the commit is done from a subdirectory so bzr "helpfully" added ruby_extension in front of ruby_extension/bzr+ssh:/<email address hidden>/~rob-burrowes/ratlas/trunk

which is *not* anymore a valid url to recognize...