bzr: ERROR: [Error 5] Access Denied: 'f:\\temp\\tmpeb__7s.pag'

Asked by Goblin on 2011-08-02

I reinstalled Windows, so I had to reinstall Bazaar as well..
Used Pageant to generate a new public/private key and added it to Pageant.
Also ran 'bzr launchpad-login tvd'.

What am I doing wrong? See log below..
It's also looking for a .ssh/known_hosts file that doesn't exist...

------

Tue 2011-08-02 21:04:20 +0200
0.047 bazaar version: 2.4b5
0.047 bzr arguments: [u'branch', u'lp:~tvd/moo/devmoo']
0.078 looking for plugins in C:/Users/Tim van Dijen/AppData/Roaming/bazaar/2.0/plugins
0.078 looking for plugins in C:/Program Files (x86)/Bazaar/plugins
0.109 encoding stdout as sys.stdout encoding 'cp850'
0.187 falling back to default implementation
0.187 failed to load system host keys: [Errno 2] No such file or directory: 'C:\\Users\\Tim van Dijen/.ssh/known_hosts'
[ 3932] 2011-08-02 21:04:20.506 INFO: Connected (version 2.0, client Twisted)
0.499 Transferred: 0kB (0.0kB/s r:0kB w:0kB)
0.499 Traceback (most recent call last):
  File "bzrlib\commands.pyo", line 946, in exception_to_return_code
  File "bzrlib\commands.pyo", line 1150, in run_bzr
  File "bzrlib\commands.pyo", line 699, in run_argv_aliases
  File "bzrlib\commands.pyo", line 721, in run
  File "bzrlib\cleanup.pyo", line 135, in run_simple
  File "bzrlib\cleanup.pyo", line 165, in _do_with_cleanups
  File "bzrlib\builtins.pyo", line 1263, in run
  File "bzrlib\bzrdir.pyo", line 918, in open_tree_or_branch
  File "bzrlib\bzrdir.pyo", line 828, in open
  File "bzrlib\bzrdir.pyo", line 863, in open_from_transport
  File "bzrlib\bzrdir.pyo", line 1590, in open
  File "bzrlib\remote.pyo", line 293, in _open
  File "bzrlib\remote.pyo", line 356, in __init__
  File "bzrlib\remote.pyo", line 368, in _probe_bzrdir
  File "bzrlib\remote.pyo", line 375, in _rpc_open_2_1
  File "bzrlib\remote.pyo", line 56, in _call
  File "bzrlib\smart\client.pyo", line 132, in call
  File "bzrlib\smart\client.pyo", line 145, in call_expecting_body
  File "bzrlib\smart\client.pyo", line 90, in _call_and_read_response
  File "bzrlib\smart\client.pyo", line 63, in _send_request
  File "bzrlib\smart\protocol.pyo", line 1309, in call
  File "bzrlib\smart\protocol.pyo", line 1133, in _write_end
  File "bzrlib\smart\protocol.pyo", line 1099, in flush
  File "bzrlib\smart\medium.pyo", line 395, in accept_bytes
  File "bzrlib\smart\medium.pyo", line 977, in _accept_bytes
  File "bzrlib\smart\medium.pyo", line 793, in _accept_bytes
  File "bzrlib\smart\medium.pyo", line 817, in _ensure_connection
  File "bzrlib\transport\ssh.pyo", line 332, in connect_ssh
  File "bzrlib\transport\ssh.pyo", line 320, in _connect
  File "bzrlib\transport\ssh.pyo", line 497, in _paramiko_auth
  File "paramiko\agent.pyo", line 78, in __init__
  File "paramiko\agent.pyo", line 109, in _send_message
  File "paramiko\win_pageant.pyo", line 136, in send
  File "paramiko\win_pageant.pyo", line 121, in _query_pageant
WindowsError: [Error 5] Access Denied: 'f:\\temp\\tmpeb__7s.pag'

0.499 return code 3

Question information

Language:
English Edit question
Status:
Solved
For:
Bazaar Edit question
Assignee:
No assignee Edit question
Solved by:
Goblin
Solved:
2011-08-08
Last query:
2011-08-08
Last reply:
2011-08-04
robincui (robincui) said : #1

OMG,i get the same error by bzr v2.3.4 and v2.2.3 after bzr launchpad-login robincui.

Martin Pool (mbp) said : #2

what are the permissions on the .pag file, and the directory that contains it?

Goblin (tvd) said : #3

I have full access on both.. But BZR appearently doesn't..
I have moved my Windows temp-dirs to a different location, which is not very uncommon..
Perhaps this has something to do with it?

Hello,

I do have the same error. Why would bzr search on c:\\temp\\ anyway and not c:\temp\ ?
If anyone finds a solution to it, help would be greatly appreciated.

I've had this error on a Vista OS. But it hasn't always been the case.. Could it be related to some late Windows update ?
No error on Windows 7 yet however.

Tx

Martin Pool (mbp) said : #5

Farid, the double-backslashes is just a quirk of the way this string is printed in the error; they're not present in the file name.

I don't know what would be causing this; I'm going to convert it to a bug.

Chris Grindstaff (cgrinds) said : #6

I suspect this is caused by the new version of pagent delivered in beta 0.61. When I kill pagent I'm prompted for my password at the cmd line and all works per normal.

Goblin (tvd) said : #7

I can confirm this.. I installed 0.60 and all works fine..

Goblin (tvd) said : #8

I guess it's up to the developers to decide whether this is a bug in Bazaar or Pagent..
I don't know how both programs communicate..

I got th some error, solved with the last snapshot version