Bazaar crashing with connection reset

Asked by Graeme Coates


I'm trying to use Bazaar to download the Bugzilla source according to their instructions. I have bzr 2.3.1 installed (from the rpmsource packages) on a RHEL5.3 server. It keeps failing - giving me connection reset errors. if someone could give me pointers as to what is wrong here, I'd be grateful = the Bugzilla guys seem to think their bzr server is OK, and I get the same behaviour on two different servers (both with the same RHEL version). Here's the Bazaar version info:

[graemec@hive ~]$ bzr --version
Bazaar (bzr) 2.3.1
  Python interpreter: /usr/bin/python 2.4.3
  Python standard library: /usr/lib64/python2.4
  Platform: Linux-2.6.18-128.1.1.el5-x86_64-with-redhat-5.3-Tikanga
  bzrlib: /usr/lib64/python2.4/site-packages/bzrlib
  Bazaar configuration: /home/graemec/.bazaar
  Bazaar log file: /home/graemec/.bzr.log

Copyright 2005-2010 Canonical Ltd.

bzr comes with ABSOLUTELY NO WARRANTY. bzr is free software, and
you may use, modify and redistribute it under the terms of the GNU
General Public License version 2 or later.

Bazaar is part of the GNU Project to produce a free operating system.

and the output from .bzr.log:

Wed 2011-05-11 14:53:10 +0100
0.038 bazaar version: 2.3.1
0.039 bzr arguments: [u'co', u'-r', u'tag:bugzilla-3.6.1', u'bzr://', u'bugzilla-3.6.1']
0.061 looking for plugins in /home/graemec/.bazaar/plugins
0.061 looking for plugins in /usr/lib64/python2.4/site-packages/bzrlib/plugins
0.071 looking for plugins in /usr/lib/python2.4/site-packages/bzrlib/plugins
0.618 Returning RevisionSpec RevisionSpec_tag for tag:bugzilla-3.6.1
0.618 encoding stdout as sys.stdout encoding 'UTF-8'
5.078 creating repository in file:///home/graemec/bugzilla-3.6.1/.bzr/.
5.082 creating branch <bzrlib.branch.BzrBranchFormat7 object at 0x2af6b2d66f10> in file:///home/graemec/bugzilla-3.6.1/
5.492 Using fetch logic to copy between RemoteRepository(bzr://'Bazaar repository format
 2a (needs bzr 1.16 or later)\n')) and CHKInventoryRepository('file:///home/graemec/bugzilla-3.6.1/.bzr/repository/')(RepositoryFormat2a())
5.492 fetch up to rev {<email address hidden>}
54.629 Transferred: 15676kB (292.9kB/s r:15672kB w:4kB)
54.709 Traceback (most recent call last):
  File "/usr/lib64/python2.4/site-packages/bzrlib/", line 926, in exception_to_return_code
    return the_callable(*args, **kwargs)
  File "/usr/lib64/python2.4/site-packages/bzrlib/", line 1126, in run_bzr
    ret = run(*run_argv)
  File "/usr/lib64/python2.4/site-packages/bzrlib/", line 691, in run_argv_aliases
  File "/usr/lib64/python2.4/site-packages/bzrlib/", line 713, in run
    return self._operation.run_simple(*args, **kwargs)
  File "/usr/lib64/python2.4/site-packages/bzrlib/", line 134, in run_simple
    return _do_with_cleanups(
  File "/usr/lib64/python2.4/site-packages/bzrlib/", line 165, in _do_with_cleanups
    result = func(*args, **kwargs)
  File "/usr/lib64/python2.4/site-packages/bzrlib/", line 1328, in run
    accelerator_tree, hardlink)
  File "/usr/lib64/python2.4/site-packages/bzrlib/", line 1444, in create_checkout
    checkout_branch.pull(self, stop_revision=revision_id)
  File "/usr/lib64/python2.4/site-packages/bzrlib/", line 1086, in pull
    possible_transports=possible_transports, *args, **kwargs)
  File "/usr/lib64/python2.4/site-packages/bzrlib/", line 194, in write_locked
    result = unbound(self, *args, **kwargs)
  File "/usr/lib64/python2.4/site-packages/bzrlib/", line 3478, in pull
    merge_tags_to_master=not source_is_master)
  File "/usr/lib64/python2.4/site-packages/bzrlib/", line 3588, in _pull
    overwrite=overwrite, graph=graph)
  File "/usr/lib64/python2.4/site-packages/bzrlib/", line 1035, in update_revisions
    overwrite, graph)
  File "/usr/lib64/python2.4/site-packages/bzrlib/", line 194, in write_locked
    result = unbound(self, *args, **kwargs)
  File "/usr/lib64/python2.4/site-packages/bzrlib/", line 3430, in update_revisions, stop_revision)
  File "/usr/lib64/python2.4/site-packages/bzrlib/", line 194, in write_locked
    result = unbound(self, *args, **kwargs)
  File "/usr/lib64/python2.4/site-packages/bzrlib/", line 685, in fetch
  File "/usr/lib64/python2.4/site-packages/bzrlib/", line 1781, in fetch
    find_ghosts=find_ghosts, fetch_spec=fetch_spec)
  File "/usr/lib64/python2.4/site-packages/bzrlib/", line 194, in write_locked
    result = unbound(self, *args, **kwargs)
  File "/usr/lib64/python2.4/site-packages/bzrlib/", line 3437, in fetch
  File "/usr/lib64/python2.4/site-packages/bzrlib/", line 73, in __init__
  File "/usr/lib64/python2.4/site-packages/bzrlib/", line 99, in __fetch
  File "/usr/lib64/python2.4/site-packages/bzrlib/", line 126, in _fetch_everything_for_search
    resume_tokens, missing_keys = self.sink.insert_stream(
  File "/usr/lib64/python2.4/site-packages/bzrlib/", line 4097, in insert_stream
    src_format, is_resume)
  File "/usr/lib64/python2.4/site-packages/bzrlib/", line 4161, in insert_stream_without_locking
  File "/usr/lib64/python2.4/site-packages/bzrlib/", line 1617, in insert_record_stream
    for _ in self._insert_record_stream(stream, random_id=False):
  File "/usr/lib64/python2.4/site-packages/bzrlib/", line 1683, in _insert_record_stream
    for record in stream:
  File "/usr/lib64/python2.4/site-packages/bzrlib/smart/", line 591, in wrap_and_count
    for record in
  File "/usr/lib64/python2.4/site-packages/bzrlib/", line 1817, in read
    for bytes in self._bytes_iterator:
  File "/usr/lib64/python2.4/site-packages/bzrlib/smart/", line 569, in iter_substream_bytes
    for record in self.iter_pack_records:
  File "/usr/lib64/python2.4/site-packages/bzrlib/smart/", line 559, in iter_stream_decoder
    for bytes in self.byte_stream:
  File "/usr/lib64/python2.4/site-packages/bzrlib/smart/", line 336, in read_streamed_body
  File "/usr/lib64/python2.4/site-packages/bzrlib/smart/", line 285, in _read_more
    raise errors.ConnectionReset(
ConnectionReset: Connection closed: Unexpected end of message. Please check connectivity and permissions, and report a bug if problems persist.

54.709 return code 3

Thanks in advance,


Question information

English Edit question
Bazaar Edit question
No assignee Edit question
Solved by:
Graeme Coates
Last query:
Last reply:
Revision history for this message
Martin Pool (mbp) said :

Hi there,

The error basically means the network connection is dropping, which is probably not something under bzr's control (though it's possible.) Is there a proxy or NAT in between you and the bugzilla bzr server? Sometimes these problems occur because of a problem with path MTU discovery, in which case something like 'sudo ifconfig eth0 mtu 1200' on the client should fix it.

Revision history for this message
Andrew Bennetts (spiv) said :

FWIW, the same command works for me. It took about 80 seconds and 17.7MB transferred. So that is suggestive of a network problem of some sort on your end.

Revision history for this message
Graeme Coates (graeme-chromosphere) said :

Thanks guys - I assumed it may have been some odd network issue, but wanted to check in case there was another cause. Some further digging shows that there is an RST being sent to the bzr client - I just need to find where it's coming from now (Andrew's confirmation that the command works is pointing me in the direction of the firewall here - I'm gonna ask for some diagnostics to be run today). Thanks for the help.


Revision history for this message
Graeme Coates (graeme-chromosphere) said :

And firewall it was - false positive from firewall packet inspection was killing the connection. Problem solved.