Can't upload the changes

Asked by Krisztian Bolla on 2009-10-07

I have a problem with upload plugin. The version now is 1.0.0dev. The problem with it, that after I commited locally the changes and gave a bzr push to a server I also would like to gave the bzr upload sftp:...... order to the server. It is always stop after authentication with the following error message: bzr: ERROR: Cannot upload to a managed bzr working tree: sftp://.....

Before this I have used upload plugin 0.1.1 and it is worked perfectly. Any idea what I am doing wrong? (I have refreshed now to bazaar 2.0 but upload 1.0.0dev doesn't worked with 1.1.19 too).

Question information

Language:
English Edit question
Status:
Answered
For:
bzr Upload plugin Edit question
Assignee:
No assignee Edit question
Last query:
2009-10-07
Last reply:
2009-10-07
Vincent Ladeuil (vila) said : #1

If you want to update the working of your remote branch, you don't want to use the bzr-upload plugin,
you want to use the https://launchpad.net/bzr-push-and-update plugin.
bzr-upload is specifically targeted to remote working tree *without* an associated branch,
using bzr-push-and-update will perform better in your case because it will be able to apply modifications
locally to the file where bzr-upload will upload the whole file.

Can you help with this problem?

Provide an answer of your own, or ask Krisztian Bolla for more information if necessary.

To post a message you must log in.