bzr upload --no-auto fails

Asked by Anita Kean on 2011-09-14

Hello

I installed bzr upload --auto to upgrade an image of
a bzr-repository on a remote server.
The remote server has now changed address, the old address no longer exists.
If I issue the command

    bzr upload --no-auto

to stop bzr attempting to upload further updates to the old server,
it fails with the error that it cannot find the repository:

> $ bzr upload --no-auto--
> Using saved location: sftp://<old_address>
> ssh: Could not resolve hostname <old_address>: Name or service not known
> bzr: ERROR: Unable to connect to SSH host <old_address>; EOF during negotiation

I've issued a bzr upload --auto to the new repository, but it always fails with the error
that it cannot resolve the old address.

Any help gratefully received.
bzr installed on a machine running ubuntu 10.04

Question information

Language:
English Edit question
Status:
Solved
For:
bzr Upload plugin Edit question
Assignee:
No assignee Edit question
Solved by:
Vincent Ladeuil
Solved:
2011-09-14
Last query:
2011-09-14
Last reply:
2011-09-14
Best Vincent Ladeuil (vila) said : #1

Hello Anita,

This is rather silly and worth fixing so I'll turn your question into a bug report.

In the mean time, you can work around the issue by doing:

   bzr config upload_location=<new_addres>

if your installation provides a recent enough bzr, otherwise, edit the branch.conf text file in .bzr/branch/branch.conf to the same effect.

Anita Kean (akean) said : #2

Thanks very much, Vincent!
Problem solved.
Very grateful.

Anita