Subversion branch support for Bazaar

bzr-svn not using cached passwords

Asked by Russel Winder on 2008-02-08

I am using Ubuntu 7.10 Gutsy Gibbon with Subversion 1.4.4. I have installed Bazaar version 1.1.0 to replace the standard 0.90.0. I am trying to access a Subversion repository that I have a Subversion checkout of using Bazaar. The repository is password protected, but as I have a checkout the information is in the cache -- I have checked this by doing a svn info on the URL and it works fine.

When I try to take a branch from the store, I get:

|> bzr branch http://scons.tigris.org/svn/scons/trunk SCons_Trunk
bzr: ERROR: Invalid http response for http://scons.tigris.org/svn/scons/trunk/.bzr/branch-format: Unable to handle http code 401: Authorization Required

So my question is, is the a bug that has already been fixed, or is it a new bug I should report.

THanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Bazaar Subversion Plugin Edit question
Assignee:
No assignee Edit question
Solved by:
Jelmer Vernooij
Solved:
2008-02-08
Last query:
2008-02-08
Last reply:
2008-02-08
Jelmer Vernooij (jelmer) said : #1

What version of bzr-svn are you using?

Russel Winder (russel) said : #2

 0.4.6-1~bazaar1~gutsy1

This is the one from the Ubuntu packages site, there didn't seem to be a 0.4.7.

Best Jelmer Vernooij (jelmer) said : #3

try using svn+http://scons.tigris.org/svn/scons/trunk as the URL. This is a bug in bzr itself that makes it abort before asking bzr-svn whether it supports the URL.

Russel Winder (russel) said : #4

Rock on.

It's taking a while (not unreasonably given there are 2640 revisions to deal with), but it is getting on with it. I expect sucvcess to be achieved.

Thanks for the very prompt responses and support. Much appreciated.

Russel Winder (russel) said : #5

Thanks Jelmer Vernooij, that solved my question.

Archimedes Trajano (trajano) said : #6

The svn+ syntax works, but on 1.6 it gives the warning
"The svn+ syntax is deprecated"
and the http:// syntax still does not work.

Russel Winder (russel) said : #7

This svn+ issue is Bug 246635 ?

more in line with the original question: It still seems to be the case that Bazaar access to Subversion stores on Tigris and Codehaus requires password entry on the commandline for each write access, the passwords cached in the Subversion files are not being used for this.

Jelmer Vernooij (jelmer) said : #8

That's a bzr bug, bug 256612

Jelmer Vernooij (jelmer) said : #9

Hmm, looks like we both responded at the same time but with a different bug #. I've marked one bug as a dupe of the other.

Archimedes Trajano (trajano) said : #10

Agreed. This just happen to be the first hit for
"bzr svn checkout 401" on google

Dan Hughes (dan-multiedit) said : #11

With the 1.6 release version of Bazaar, I get prompted for a password for every access to the svn repository when using a bzr co svn://... branch. The svn repository is being provided via svnserve and requires authorization for all access. I did not have this issue with bzr 1.5 and bzr-svn 4.10. Is there any workaround to have the password read from the svn password cache?

Dan

Jelmer Vernooij (jelmer) said : #12

If there is a password present in the Subversion cache, bzr-svn will still try to use it. If that doesn't work, it will prompt.

Dan Hughes (dan-multiedit) said : #13

There is a password in the Subversion cache. I can do a svn log svn://... and it will work without a password prompt. Also it works if I use the 4.10 version of bzr-svn with bzr 1.5. It stopped working when the svn bindings were moved into bzr-svn. FYI, the passwords are being cached in svn.simple for svnserver instead of svn.ssl.server.

Russel Winder (russel) said : #14

I haven't got any actual data on this issue immediately to hand, but my recollection is that I have no problem with Subversion stores over https:// but I do have a problem with Subversion stores over http:// -- so Codehaus gives me no problem, but Tigris makes me type a password for every write access. All the passwords are cached as svn never asks it is only bzr that asks and it always asks.