problems adding files: no module named subvertpy error

Asked by kesten broughton

I've set up a local repo for developing blender.
I pull to a pristine mirror of the trunk.
Then i pull to a local-trunk branch (usually bzr merge) and then merge again to my features-branch.
This had worked, but on my most recent attempt I got compile errors from missing directories. It seems that for files already existing, bzr can't create them. When I do a bzr merge from blender-svn to local-trunk, it says there is nothing to be done. But there are folders in blender-svn that aren't in local-trunk. (Yes, i commmitted blender-svn after synching with

I tried creating a diff of the two branches and applying the patch. The patch creates somes files. I try bzr add . but it terminates with an error and appears that it was not successful (despite the adding... suggesting partial success).

kesten@kesten-K42Jr:~/VCP/Bazaar/blender/local-trunk$ bzr add .
adding blender/intern/raskter
adding blender/intern/raskter/CMakeLists.txt
adding blender/intern/raskter/SConscript
adding blender/intern/raskter/raskter.c
adding blender/intern/raskter/raskter.h
adding blender/release/datafiles/
bzr: ERROR: Unable to import library "subvertpy": bzr-svn: No module named subvertpy

local-trunk$ bzr commit -m "apply diff from blender-svn"
Committing to: /home/kesten/VCP/Bazaar/blender/local-trunk/
bzr: ERROR: No changes to commit. Please 'bzr add' the files you want to commit, or use --unchanged to force an empty commit.

I thought the subvertpy error (which i get all the time now) was related to trying to get bzr-svn working. But i didn't think it would affect the core bzr methods.

any thoughts on what's going wrong?


Question information

English Edit question
Bazaar Subversion Plugin Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Jelmer Vernooij (jelmer) said :

bzr is trying to open one of your local directories with bzr-svn because it contains a Subversion control directory (".svn").

You can either uninstall bzr-svn or remove this directory to work around this issue.

Can you help with this problem?

Provide an answer of your own, or ask kesten broughton for more information if necessary.

To post a message you must log in.