Need help running nautilus bzr plugin

Asked by Matt Wilson on 2008-03-26

I'm running ubuntu gutsy, and I can use olive-gtk to work with my repository. I want to try out the nautilus integration. I started nautilus, navigated to my folder, but didn't see anything like what was in the screenshots.

What do I need to do to enable the nautilus integration?

Question information

Language:
English Edit question
Status:
Answered
For:
Bazaar GTK+ Frontends Edit question
Assignee:
No assignee Edit question
Last query:
2008-03-26
Last reply:
2009-11-17
Martin Albisetti (beuno) said : #1

There are a few known problems with the current version of nautilus integration, which led to deactivating it by default. They have been addressed in this development cycle, so it should work with the next version by default.
Please stay tuned in the following week or so :D

alecwh (alecwh) said : #2

Any update about this? I would really like to use the integration also. I'm on Ubuntu Hardy, and the problem stands...

Jelmer Vernooij (jelmer) said : #3

It's enabled by default again as of intrepid.

Daniel Milde (daniel-milde) said : #4

Really? I can't see any difference in Intrepid.

I have nautilus-python and bzr-gtk installed, but no bzr-nautilus integration present...

Jelmer Vernooij (jelmer) said : #5

Do you have python-nautilus installed?

It may also be that you're hitting http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=501597

Daniel Milde (daniel-milde) said : #6

Yes, I have python-nautilus.

In /usr/share/pyshared-data/bzr-gtk I have just one line about nautilus:

/usr/share/pyshared/bzrlib/plugins/gtk/nautilus-bzr.py=f

Nothing about /usr/lib/nautilus/extensions-2.0/python or /usr/lib/nautilus/extensions-1.0/python

Shouldn't I install nautilus-bzr somehow? I have found no information about some special installation...

Thanks

Daniel Milde (daniel-milde) said : #7

Tried on another computer with clean installation of 8.10, but same result.

Installed bzr, bzr-gtk and python-nautilus. Olive-gtk works, nautilus integration doesn't.

Any solution? Or should I set it as a bug report?

Jelmer Vernooij (jelmer) said : #8

Please report a bug against the ubuntu package of bzr-gtk (not bzr-gtk itself)

I'm confused, that bug report says that this there is a fix released in Ubuntu. I am using Karmic and I don't have any nautilus integration. Is there anything I need to do?

Can you help with this problem?

Provide an answer of your own, or ask Matt Wilson for more information if necessary.

To post a message you must log in.