GTK+ Frontends to Various Bazaar Commands

Is Bazzar GTK+ install documentation for Windows avalible?

Asked by SAL-e on 2008-03-17

Hi,

I see on Bazaar Plugins page (http://bazaar-vcs.org/BzrPlugins) that BzrGTK+ is working for Windows, but for some reason I can't find any documentation about Windows support.

I am looking to see what is the system requirements and basic install instructions.

Thank you,
SAL-e

Question information

Language:
English Edit question
Status:
Answered
For:
Bazaar GTK+ Frontends Edit question
Assignee:
No assignee Edit question
Last query:
2008-03-17
Last reply:
2008-03-19
Remco Blumink (remcoblumink) said : #1

Hi,
I have a similar question, maybe even a bug, but unsure.

You need to install several packages to get python to do things with the GTK interface, but i do not remember which ones exactly :(
The dependencies are listed somewhere. You need to install the gtk+runtime, pygtk, pycairo and py-gobject at least to get some action.
Strangely, the gladewin32 project stopped existing. However, the GTK+runtime is installable from http://sourceforge.net/projects/gtk-win/

Pygtk should include the libglade-2.0.0.dll file, but it doesnt or so, as I keep getting the error that olive needs this file.
Maybe someone else knows how to?

Remco Blumink (remcoblumink) said : #2

As an addition to the above,
I got it running later on. At This page, there is a list of requiremens: http://bazaar-vcs.org/WindowsInstall
the trick is to just install all of them (really neat...:(

Problem: the GTK+-Runtime is not at that link!
 --> here it is: http://sourceforge.net/project/showfiles.php?group_id=98754

You need the GTK+ runtime AND libglade.

Besides, you'll also need libxml. http://gnuwin32.sourceforge.net/packages/libxml2.htm

This leads to olive loading up with errors at my WinXP box. Haven't tested more thouroughly

Can you help with this problem?

Provide an answer of your own, or ask SAL-e for more information if necessary.

To post a message you must log in.