bzr'ing to a ntfs partition

Asked by Remco Blumink on 2008-03-12

Hi,
I run a dualboot system (WinXP and Ubuntu Gutsy). I use bazaar happily under both OS'es, but I sometimes would like to be able to update or commit in my windows folders from ubuntu. It stops when doing that with saying no permission(error no 1). Is this correct behaviour?

Normally, I can both read and write to my windows partition.

Question information

Language:
English Edit question
Status:
Solved
For:
Bazaar GTK+ Frontends Edit question
Assignee:
No assignee Edit question
Solved by:
Remco Blumink
Solved:
2008-04-01
Last query:
2008-04-01
Last reply:
2008-03-17
Remco Blumink (remcoblumink) said : #1

In addition, when i do sudo {bzr operation} it works correctly.
(though i need to type in my ssh password then :( Can't figure out how to do that automagically
)

Szilveszter Farkas (phanatic) said : #2

I guess your Windows partition is not mounted correctly under Ubuntu (it has some issues with permissions, if using Bazaar as root works fine).

SAL-e (sal-electronics) said : #3

Hi Remco,

I don't know why "bzr" needs root access in order to work with NTFS disk from Ubuntu, but you can try this:
1. Open terminal window
2. Type command "sudo -i" You still need to type your password, but only once. After that all commands from this terminal window will be run as 'root', so be careful.
3.Try to 'bzr' inside this terminal session.

Also you can try to boot in Windows and navigate to your bzr repository and change permissions for this folder. Add 'Guest' user to have full access. Then try to boot back in Ubuntu i try again to run 'bzr' as normal user. I think this is happening because normal user is not recognized by NTFS.

Good luck,
SAL-e

Remco Blumink (remcoblumink) said : #4

I finally discovered what the problem was, my fault, not yours..
The issue is that you need to set the uuid value for the disk to yours in /etc/fstab. Strangely this is only needed for version control programs (had the same with svn)