import git (once svn) repository from googlecode

Asked by Dominique Lasserre on 2011-10-12

I want to import a git repository from Google Code. But it fails with http://launchpadlibrarian.net/82551568/chimaira-development-chimaira-packages.log :

2011-10-11 16:25:12 INFO Starting job.
2011-10-11 16:25:12 INFO Getting exising bzr branch from central store.
2011-10-11 16:25:13 INFO [chan bzr SocketAsChannelAdapter] Opened sftp connection (server version 3)
2011-10-11 16:25:13 INFO 35 bytes transferred
2011-10-11 16:25:13 INFO [chan bzr SocketAsChannelAdapter] Opened sftp connection (server version 3)
2011-10-11 16:25:14 INFO Importing branch.
2011-10-11 16:25:21 INFO finding revisions to fetch 0
2011-10-11 16:25:22 INFO finding revisions to fetch:generating index 0/1918
2011-10-11 16:25:23 INFO finding revisions to fetch 1
2011-10-11 16:25:23 INFO
Traceback (most recent call last):
  File "/srv/importd.launchpad.net/production/launchpad-rev-14124/scripts/code-import-worker.py", line 98, in <module>
    sys.exit(script.main())
  File "/srv/importd.launchpad.net/production/launchpad-rev-14124/scripts/code-import-worker.py", line 93, in main
    return import_worker.run()
  File "/srv/importd.launchpad.net/production/launchpad-rev-14124/lib/lp/codehosting/codeimport/worker.py", line 550, in run
    return self._doImport()
  File "/srv/importd.launchpad.net/production/launchpad-rev-14124/lib/lp/codehosting/codeimport/worker.py", line 740, in _doImport
    inter_branch.fetch(limit=revision_limit)
  File "/srv/importd.launchpad.net/production/launchpad-rev-14124/bzrplugins/optional/git/branch.py", line 666, in fetch
    self.fetch_objects(stop_revision, fetch_tags=fetch_tags, limit=limit)
  File "/srv/importd.launchpad.net/production/launchpad-rev-14124/bzrplugins/optional/git/branch.py", line 689, in fetch_objects
    determine_wants, self.source.mapping, limit=limit)
  File "/srv/importd.launchpad.net/production/launchpad-rev-14124/bzrplugins/optional/git/fetch.py", line 676, in fetch_objects
    limit)
  File "/srv/importd.launchpad.net/production/launchpad-rev-14124/bzrplugins/optional/git/fetch.py", line 491, in import_git_objects
    target_git_object_retriever, trees_cache)
  File "/srv/importd.launchpad.net/production/launchpad-rev-14124/bzrplugins/optional/git/fetch.py", line 370, in import_git_commit
    parent_trees = trees_cache.revision_trees(rev.parent_ids)
  File "/srv/importd.launchpad.net/production/launchpad-rev-14124/bzrplugins/optional/git/object_store.py", line 112, in revision_trees
    return list(self.iter_revision_trees(revids))
  File "/srv/importd.launchpad.net/production/launchpad-rev-14124/bzrplugins/optional/git/object_store.py", line 106, in iter_revision_trees
    for tree in self.repository.revision_trees(todo):
  File "/srv/importd.launchpad.net/production/launchpad-rev-14124/eggs/bzr-2.5.0dev2_r6152-py2.6-linux-x86_64.egg/bzrlib/vf_repository.py", line 1794, in revision_trees
    for inv in inventories:
  File "/srv/importd.launchpad.net/production/launchpad-rev-14124/eggs/bzr-2.5.0dev2_r6152-py2.6-linux-x86_64.egg/bzrlib/repofmt/groupcompress_repo.py", line 981, in _iter_inventories
    raise errors.NoSuchRevision(self, record.key)
bzrlib.errors.NoSuchRevision: CHKInventoryRepository('file:///srv/importd.launchpad.net/data/worker-for-branch-517295/bzr_branch/.bzr/repository/') has no revision ('git-v1:a416d1fb4662544f6bac0bbc528b5dc8d1f39f87',)
Import failed:
Traceback (most recent call last):
Failure: twisted.internet.error.ProcessTerminated: A process has ended with a probable error condition: process ended with exit code 1.

See also https://code.launchpad.net/~chimaira-development/chimaira/packages for branch site. Actually launchpad fetches from "https://code.google.com/p/chimaira.git" but "https://code.google.com/p/chimaira" results same error.

Perhaps it is important that this git repo was a svn repo originally.

How can I prevent this error and achieve an successful import? Thanks in advance.

Question information

Language:
English Edit question
Status:
Answered
For:
Bazaar Git Plugin Edit question
Assignee:
Jelmer Vernooij Edit question
Last query:
2011-10-18
Last reply:
2013-05-18
Jelmer Vernooij (jelmer) said : #1

Sorry for taking this long to get back to you. I have tried to reproduce the issue locally, but the branch imports just fine here.

Have you tried removing the branch and creating it again from scratch?

Dominique Lasserre (lasall) said : #2

Thank you for answering this question. I am glad that you could import this branch. But unfortunately it is not working yet. What do you mean with "creating from scratch"?

I have tried to import this branch (from gcode) to a private one (https://code.launchpad.net/~lasall/chimaira/trunk). But the error log is quite similar.

Jelmer Vernooij (jelmer) said : #3

It looks like this is some sort of bug in our git importer; I've filed one (should be linked to this question).

Since I can't reproduce it locally, I hope that the newer version of bzr-git that is due to be deployed on Launchpad will fix the issue.

Dr. Amr Osman (dr3mro) said : #4

I am also affected plz fix

pataquets (pataquets) said : #5

+1

Jelmer Vernooij (jelmer) said : #6

Responding here doesn't help. Please follow up on the bug report.

Can you help with this problem?

Provide an answer of your own, or ask Dominique Lasserre for more information if necessary.

To post a message you must log in.