n00b questions about installing the ppa repo

Asked by teknopaul on 2018-01-13

how do I install this code?

Forgive my ignorance never use bzr before, I'm trying to move of P4

I tried a few things but I dont grok PPA yet.

sudo add-apt-repository ppa:bzr-fastimport
sudo add-apt-repository ppa:bzrp4

I tried running from source by dumping the code to ./foo and

BZR_PLUGIN_PATH=./foo bzr selftest bzrp4
bzr: ERROR: tests not available. Install the python-bzrlib.tests package to run the bzr testsuite.

sudo aptitude install python-bzrlib
python-bzrlib is already installed at the requested version (2.7.0-2ubuntu3.1)

Question information

Language:
English Edit question
Status:
Open
For:
Bazaar Fast Import Edit question
Assignee:
No assignee Edit question
Last query:
2018-01-13
Last reply:
teknopaul (teknopaul) said : #1

I think I manged to get somethinn to run (no more python errors)

sudo aptitude install bzr
sudo aptitude install perforce-p4python
mkdir -p ~/.bazaar/plugins
cd -p ~/.bazaar/plugins
bzr branch lp:bzrp4

when I try to run it it acts as if
a) I got the syntax wrong
b) Its got nothing to do with bzr???

~/.bazaar/plugins/bzrp4/p4-fast-export.py export --verbose //depot/cairoruler@all

Usage: p4-fast-export.py export [options] //depot/path[@revRange]

Creates a new git repository and imports from Perforce into it

Options:
  --branch=BRANCH
  --detect-branches
  --changesfile=CHANGESFILE
  --silent
  --detect-labels
  --verbose
  --import-local Import into refs/heads/ , not refs/remotes
  --max-changes=MAXCHANGES
  --keep-path Keep entire BRANCH/DIR/SUBDIR prefix during import
  --use-client-spec Only sync files that are included in the Perforce
                        Client Spec
  --git-dir=GITDIR
  -h, --help show this help message and exit

teknopaul (teknopaul) said : #2

I managed to get something to run with git_p4.py run by hand

chmod ~/.bazaar/plugins/bzrp4/*.py

~/.bazaar/plugins/bzrp4/git_p4.py export //depot/cairoruler@all > cairoruler.fi
bzr fast-import cairoruler.fi cairoruler.bzr

This creates a directory cairoruler.bzr/p4/master.remote which seems to be the workspace.

So Ithink perhaps is the plugins systems thats not wrking

bzr fast-export-from-p4
bzr: ERROR: unknown command "fast-export-from-p4"

 bzr plugins output includes

bzrp4
  (no description)
...
fastimport 0.14.0dev
  FastImport Plugin

Can you help with this problem?

Provide an answer of your own, or ask teknopaul for more information if necessary.

To post a message you must log in.