Explorer does not open anymore

Asked by Thomas Moseler

Just until today, Bazaar Explorer worked fine on my Windows 7 machine.
Now it does not open anymore all of a sudden.

I have uninstalled and reinstalled the 2.5.1 Standalone Version of bazaar. I am also using Cygwin, and have Bazaar and Python also installed in Cygwin, maybe this is causing conflicts? Here are the contents of the log:

Thu 2012-06-14 18:49:36 +0200
0.078 bazaar version: 2.5.1
0.078 bzr arguments: [u'explorer']
0.078 looking for plugins in C:/Users/tommi/AppData/Roaming/bazaar/2.0/plugins
0.078 looking for plugins in C:/Program Files/Entwicklung/Bazaar/plugins
0.172 encoding stdout as osutils.get_user_encoding() 'cp1252'
0.375 Deprecated function called
Called from:
  File "bzrlib\lazy_import.pyo", line 200, in _import
  File "C:/Program Files/Entwicklung/Bazaar/plugins\explorer\lib\explorer.py", line 32, in <module>
  File "C:/Program Files/Entwicklung/Bazaar/plugins\explorer\lib\desktop_env.py", line 158, in <module>
0.609 Deprecated method called
Called from:
  File "C:/Program Files/Entwicklung/Bazaar/plugins\explorer\lib\explorer.py", line 166, in __init__
  File "C:/Program Files/Entwicklung/Bazaar/plugins\explorer\lib\explorer.py", line 258, in _refresh_user_configuration
  File "C:/Program Files/Entwicklung/Bazaar/plugins\explorer\lib\explorer.py", line 265, in get_default_editor
0.609 loading explorer extensions for clothes ['Bazaar support', 'Register on Launchpad']
0.609 explorer extensions provided by the colo plugin in C:/Program Files/Entwicklung/Bazaar/plugins/colo/explorer
0.656 Traceback (most recent call last):
  File "bzrlib\commands.pyo", line 920, in exception_to_return_code
  File "bzrlib\commands.pyo", line 1131, in run_bzr
  File "bzrlib\commands.pyo", line 673, in run_argv_aliases
  File "bzrlib\commands.pyo", line 695, in run
  File "bzrlib\cleanup.pyo", line 136, in run_simple
  File "bzrlib\cleanup.pyo", line 166, in _do_with_cleanups
  File "C:/Program Files/Entwicklung/Bazaar/plugins\explorer\lib\commands.py", line 162, in run
  File "C:/Program Files/Entwicklung/Bazaar/plugins\explorer\lib\explorer.py", line 208, in __init__
  File "C:/Program Files/Entwicklung/Bazaar/plugins\explorer\lib\wt_browser.py", line 49, in __init__
  File "C:/Program Files/Entwicklung/Bazaar/plugins\explorer\lib\wt_browser.py", line 450, in __init__
  File "C:/Program Files/Entwicklung/Bazaar/plugins\explorer\lib\wt_browser.py", line 685, in __init__
  File "C:/Program Files/Entwicklung/Bazaar/plugins\explorer\lib\wt_browser.py", line 628, in __init__
  File "C:/Program Files/Entwicklung/Bazaar/plugins\qbzr\lib\treewidget.py", line 1357, in __init__
  File "C:/Program Files/Entwicklung/Bazaar/plugins\qbzr\lib\treewidget.py", line 1693, in create_context_menu
  File "bzrlib\lazy_import.pyo", line 116, in __call__
  File "bzrlib\lazy_import.pyo", line 85, in _resolve
  File "bzrlib\lazy_import.pyo", line 200, in _import
  File "C:/Program Files/Entwicklung/Bazaar/plugins\qbzr\lib\diff.py", line 42, in <module>
  File "C:/Program Files/Entwicklung/Bazaar/plugins\qbzr\lib\util.py", line 128, in get_option
  File "C:/Program Files/Entwicklung/Bazaar/plugins\qbzr\lib\util.py", line 109, in _load
  File "bzrlib\util\configobj\configobj.pyo", line 1223, in __init__
  File "bzrlib\util\configobj\configobj.pyo", line 1306, in _load
ParseError: Invalid line at line "1".

0.656 couldn't find apport bug-reporting library: No module named apport
0.671 return code 4

When I run it from the Windows command shell, it gives the same message, but adds at the end

bzr 2.5.1 on python 2.6.6 (Windows-7-6.1.7600)
arguments: ['bzr', 'explore']
plugins: bzrtools[2.5.0], changelog_merge[2.5.1], colo[0.4.0],
    explorer[1.2.2], fastimport[0.14.0dev], git[0.6.8], launchpad[2.5.1],
    loom[2.3.0dev], netrc_credential_store[2.5.1], news_merge[2.5.1],
    pipeline[1.4.0], qbzr[0.22.3], rewrite[0.6.4dev], svn[1.2.2],
    upload[1.2.0dev], xmloutput[0.8.8]
encoding: 'cp1252', fsenc: 'mbcs', lang: None

*** Bazaar has encountered an internal error. This probably indicates a
    bug in Bazaar. You can help us fix it by filing a bug report at
    including this traceback and a description of the problem.

Maybe this information is helpful.

Question information

English Edit question
Bazaar Explorer Edit question
No assignee Edit question
Solved by:
Thomas Moseler
Last query:
Last reply:
Revision history for this message
Thomas Moseler (tmoseler) said :

O.K. I fixed it for now by restoring a system image of my entire windows, since that was quite recent. If someone knows the answer, still appreciated.

Revision history for this message
Alexander Belchenko (bialix) said :

ParseError: Invalid line at line "1".

Some of configuration files in your APPDATA/bazaar/2.0 directory were broken, maybe you had disk crash or something like that.
Maybe it was qbzr.conf or maybe some config file of bzr-explorer from explorer subfolder.

I'd recommend if next time you get copy of bazaar config files from mentioned folders before you restore your Windows.

Those config files are plain INI-like files, so it should be possible to "fix" them in any decent text editor. Even if you're unable or unsure how to fix config files, you can just delete qbzr.conf and explorer configs, they will be re-created next time you run bzr. (but maybe some of yours personal settings will be lost :-/)

Revision history for this message
Thomas Moseler (tmoseler) said :

Thanks for then answer. I think I will be able to find it from my profile and will try as you say the next time it happens.