how to save the authendication credentials in Bazaar Explorer?

Asked by Vijaya Kumar on 2011-11-11

Hi,

I have configured bazaar smart server with apache and restricted access using 'AuthUserfile' in apache httpd.conf.

From (Bazaar Explorer) client if i try to do any operation it is asking me the credentials again and again.

Is there any way to save the login credentials, so that i can save the credentilas at the first time of my login?

Regards,
Vijay

Question information

Language:
English Edit question
Status:
Solved
For:
Bazaar Explorer Edit question
Assignee:
No assignee Edit question
Solved by:
Vijaya Kumar
Solved:
2011-11-11
Last query:
2011-11-11
Last reply:
2011-11-11
Vijaya Kumar (vijayakumar-cm) said : #1

I installed this plugin "wincrypt_credential_store" .. now it stores the password but asking me the username again and again :(

Alexander Belchenko (bialix) said : #2

Vijaya Kumar пишет:
> Question #178357 on Bazaar Explorer changed:
> https://answers.launchpad.net/bzr-explorer/+question/178357
>
> Vijaya Kumar gave more information on the question:
> I installed this plugin "wincrypt_credential_store" .. now it stores the
> password but asking me the username again and again :(

You need to edit your authentication.conf and put desired username
(and maybe password) in there. See bzr documentation for details.

--
All the dude wanted was his rug back

Vijaya Kumar (vijayakumar-cm) said : #3

In what format i need to put my username and passwd?

I tried to just put my username and its giving me this error

bzr: ERROR: Error(s) parsing config file C:/Documents and Settings/300228319/Application Data/bazaar/2.0/authentication.conf:
Invalid line at line "1".

Vijaya Kumar (vijayakumar-cm) said : #4

this works for me :)

authentication.conf:
[DEFAULT]
user =
password =

Alexander Belchenko (bialix) said : #5

Vijaya Kumar пишет:
> Question #178357 on Bazaar Explorer changed:
> https://answers.launchpad.net/bzr-explorer/+question/178357
>
> Status: Answered => Solved
>
> Vijaya Kumar confirmed that the question is solved:
> this works for me :)
>
> authentication.conf:
> [DEFAULT]
> user =
> password =
>

You can have several sections for different servers as following

[myserver]
user = desired-login-name
password = secret
host = bzr://myserver.net

See
http://doc.bazaar.canonical.com/bzr.2.4/en/user-reference/authentication-help.html
for more details

--
All the dude wanted was his rug back