bzrw.exe doesn't start on Windows 7 x64

Asked by Ken Halprin on 2010-11-03

Just downloaded "bzr-2.2.1-3-setup.exe". Ran the install without a problem (used default setup options except for the shell extension and a couple of plugins). When I run bzrw.exe it churns for a second then nothing. Same thing happens when running as Administrator. Bzr.exe appears to run OK - it spits out usage information.

Any ideas?

Question information

Language:
English Edit question
Status:
Solved
For:
Bazaar Explorer Edit question
Assignee:
No assignee Edit question
Solved by:
Ken Halprin
Solved:
2010-11-04
Last query:
2010-11-04
Last reply:
Ken Halprin (khalprin) said : #1

I found the problem after reading a similar question posted by Andir. The Launchpad plugin must be installed. Here's the entry from .bzr.log when trying to run bzrw *without* launchpad installed:

Wed 2010-11-03 12:15:36 -0500
0.453 bazaar version: 2.2.1
0.453 bzr arguments: [u'explorer']
0.453 looking for plugins in C:/Users/khalprin/AppData/Roaming/bazaar/2.0/plugins
0.453 looking for plugins in C:/Program Files (x86)/Bazaar/plugins
2.200 encoding stdout as osutils.get_user_encoding() 'cp1252'
2.855 Traceback (most recent call last):
  File "bzrlib\commands.pyo", line 912, in exception_to_return_code
  File "bzrlib\commands.pyo", line 1112, in run_bzr
  File "bzrlib\commands.pyo", line 690, in run_argv_aliases
  File "bzrlib\commands.pyo", line 705, in run
  File "bzrlib\cleanup.pyo", line 135, in run_simple
  File "bzrlib\cleanup.pyo", line 165, in _do_with_cleanups
  File "C:/Program Files (x86)/Bazaar/plugins\explorer\lib\commands.py", line 161, in run
  File "bzrlib\lazy_import.pyo", line 106, in __getattribute__
  File "bzrlib\lazy_import.pyo", line 89, in _replace
  File "bzrlib\lazy_import.pyo", line 192, in _import
  File "C:/Program Files (x86)/Bazaar/plugins\explorer\lib\explorer.py", line 31, in <module>
  File "C:/Program Files (x86)/Bazaar/plugins\explorer\lib\hosted_url_resolver.py", line 20, in <module>
ImportError: No module named launchpad

2.855 return code 3