Bazaar Explorer doesn't load

Asked by Andir on 2010-11-02

Windows XP

I had installed Bazaar at one point... Explorer worked fine. I ended up removing Bazaar and installing it later, but I removed things like the Tortoise extensions which I didn't need. (Well, I didn't check them moreso than removed them.)

Now, Explorer doesn't load. If I launch it from the command line using "bzrw explorer" I get no errors, no windows... nothing. Is there a log file someone that would give me more information?

Question information

English Edit question
Bazaar Explorer Edit question
No assignee Edit question
Last query:
Last reply:
Gary van der Merwe (garyvdm) said : #1

Log file: My Documents\.bzr.log
If there is no info in there, please run "bzr explorer" from the command line (note no 'w'.)

Andir (nschubach) said : #2

bzrw is what the shortcut used...

Using bzr I get an error:
bzr: ERROR: No module named launchpad
You may need to install this Python library separately.

I didn't install the launchpad part of it because that's the Web hosting site(?) How can I keep it from looking for this?

I didn't see anything in appdata\bazaar\2.0\bazaar.conf to denote that it should load that.

The bazaar\plugins folder has no "manifest" files that I'm aware of.
app-suite-qbzr.ini in plugins\explorer\ had no mention of launchpad, nor did app-suite-bzr-gtk.ini or menus-for-ides.xml

In fact, there's little to nothing found in any plain text file concerning launchpad in any of the bazaar folders I have... I even tried removing the folders in the plugins called launchpad thinking it was keying off that.

Andir (nschubach) said : #3

I found a reference to launchpad in the file (lugins\explorer\lib\ and removed the line with hosted_url_resolver figuring I could prevent it from loading that... that ended poorly.

Commented some more lines referencing this hosted_url_resolver (or replaced with "None" per the return lines nearby) and it seems to have loaded.

Not sure why I'd have to do that if I didn't install the Launchpad support, but /shrug.

Can you help with this problem?

Provide an answer of your own, or ask Andir for more information if necessary.

To post a message you must log in.