Parent Location not defined?

Asked by philw on 2010-06-04

I'm starting to use Bazaar Explorer with a repository. It's tracking changes just fine and pushing them to a remote repository I also created. Looking at the UI I see that "working tree is up to date at revision 38" which sounds good, but also a warning "No parent location defined yet", which is worrying.

I tried "binding" my local repository to the place I push it to, which worked, but did not make the warning message go away. I searched everywhere, but I can't find it.

I'm sure it's simple, but can someone tell me:
 (a) what does the message mean?
 (b) is it important, and if so, how do I make it go away?

thanks...

(Background: the remote version of the repository will be shared with others once I figure out how it all works. So the "golden" copy is the remote version, although I'm not sure if that matters or not.)

Question information

Language:
English Edit question
Status:
Solved
For:
Bazaar Explorer Edit question
Assignee:
No assignee Edit question
Solved by:
Alexander Belchenko
Solved:
2010-06-05
Last query:
2010-06-05
Last reply:
2010-06-05
Gordon Tyler (doxxx) said : #1

The parent location is the location from which the local branch was branched. How did you create the remote and local repositories and branches?

Best Alexander Belchenko (bialix) said : #2

This message is harmless. You can just resize bottom window with tis message down to make it invisible.

Parent location is the location from where you pull. You can simply pull once after successfull push to your remote server to set this location. Pull after push will be no-op so it's just setting the parent location for your branch.

For more information on parent location see: http://doc.bazaar.canonical.com/bzr.2.1/en/user-reference/configuration-help.html#parent-location

philw (philip-wigglesworth) said : #3

Yes, that's it - thanks all.
(1) I created the initial repository from a local copy of my code, then "pushed" that to a network location.
(2) The message does indeed disappear once I pulled from the network location.

I think I had only "pushed" before (there's only me making changes today...), but this "parent location" is set when you pull as stated above. So doing a "pull" fixes it. I also note that the entry ion the "branch.conf" file for parent location is set at this point. I'm using SFTP so as a second step I edited that file so I don't need to type the password every time.

Excellent.

philw (philip-wigglesworth) said : #4

Thanks Alexander Belchenko, that solved my question.