BZR_LOG=/dev/null has no effect using the Bazaar Plugin

Asked by arno_b on 2009-11-10

The env BZR_LOG=/dev/null desactivate the .bzr.log (it works using bzr in command line).
But using the Bazaar Plugin, the log file is still filled.

Is that a bug?
How can I desactivate the log?

Question information

Best Guillermo Gonzalez (verterok) said : #1

Hi,

As the plugin spawns it own bzr process, I think if the env var it set at the session level it should work if it's not, please convert thsi question into a Bug.

Also, I think that adding an option in the Bazaar plugin preferences to enable/disable the log might be a good idea.

Thanks.

arno_b (arno.b) said : #2

Thanks Guillermo Gonzalez, that solved my question.