no team menu

Asked by Michaël Vanderheeren on 2009-01-13

I've got a php project, loaded with bazaar into eclipse. Bzr preferences work in eclipse. but i don't get any special entries in the team menu except for "apply patch" and the greyed "share project"

Question information

Language:
English Edit question
Status:
Solved
For:
Bazaar Plugin for Eclipse Edit question
Assignee:
No assignee Edit question
Solved by:
Michaël Vanderheeren
Solved:
2009-01-23
Last query:
2009-01-23
Last reply:
2009-01-23
Guillermo Gonzalez (verterok) said : #1

did you have this project under other version control? i.e: svn, cvs?
if that's the case, you need to remove that binding (project <-> vcs) in order to enabled a different vcs.
This is not a bzr-eclipse issue, eclipse creates the binding, and bzr-eclipse can't override or replace it, until it's cleared.

A simple solution, 'll be to delete the project (not the contents in the file system) and import it from: File --> import --> Existing projects into workspace

No other version control. But it was checked out with the bzr command on the console and afterwards loaded into eclipse... This is related to the "not able to share project bug" i think...

Guillermo Gonzalez (verterok) said : #3

hmm, I think this is related to bug #320645.
If you are importing the project, bzr-eclipse 'll automatically detect if the project is under bzr control, and share it by default.

Also I tried to do this, and it worked, so i think it might be a config/setup problem.

please remove the project, and import it again, then check the eclipse error logs.

Thanks!