cast error

Asked by Jason McVetta on 2008-10-01

I was able to install bzr-eclipse without problem. It recognized my project as being bzr-controlled (I have been using command line bzr to control it). However, when I try to do any bzr action in Eclipse, it always throws the same error:

"[B cannot be cast to java.lang.String"

I am using Python 2.5.2, Bazaar 1.3.1, xmloutput 0.8.0, Eclipse 3.3.2, and the latest bzr-eclipse from the update site.

Question information

Language:
English Edit question
Status:
Solved
For:
Bazaar Plugin for Eclipse Edit question
Assignee:
No assignee Edit question
Solved by:
Guillermo Gonzalez
Solved:
2008-10-01
Last query:
2008-10-01
Last reply:
2008-10-01
Best Guillermo Gonzalez (verterok) said : #1

Hi!
The error is an incompatiblility between bzr-eclipse and bzr.xmloutput, please check the installed version of bzr-eclipse, it should be 1.1.0.

Cheers,

Jason McVetta (jmcvetta) said : #2

Interesting... before I asked this question, I ran Eclipse's update command on the plugin, and it said no updates were available. After reading Guillermo's answer, I uninstalled the plugin, then re-installed from the update site. That fixed the problem.

Jason McVetta (jmcvetta) said : #3

Thanks Guillermo Gonzalez, that solved my question.