Uninstall, remove or update Eclipse-BZR 1.1.0

Asked by Dario Ruellan on 2010-02-24

Hi. I need some help with this issue.
I want to update my eclipse-bzr version 1.1.0 to the new 1.1.1 trunk, but using the repository http://verterok.com.ar/bzr-eclipse/update-site Eclipse tells me that there is no update available.
If I try to force an update via Install New Software (I can see the 1.1.1 version there), Eclipse shows an error: Eclipse plugin for Bazaar will be ignored because it is already installed, and updates are not permitted.

If I try to uninstall the plugin first, the option shows up dimmed.
If I delete the files from "features" and "plugin" folders, the plugin is not longer available on preferences, but still get listed as installed.

I think something got messed up on this installation. Is there some hope or I must think on a total reinstall of the platform?
Running Eclipse 3.5.0 (Aptana 1.5 Install).

Thanks in advance.

Question information

Language:
English Edit question
Status:
Solved
For:
Bazaar Plugin for Eclipse Edit question
Assignee:
No assignee Edit question
Solved by:
Dario Ruellan
Solved:
2010-02-25
Last query:
2010-02-25
Last reply:
2010-02-25
Guillermo Gonzalez (verterok) said : #1

Hi,

That's weird, looks like a eclipse p2 issue.

You shouldn't delete plugins/features directories (of plugins installed via update manager) manually because references to the plugin are kept in other p2 configuration files.

Please try starting eclipse using -clean option.

Regards,

Dario Ruellan (druellan) said : #2

Hi Guillermo, thanks for the answer, but even using -clean still the plugin in not uninstallable. I've found a .eclipse folder inside my userspace which have the configs. Deleting it and bazaar from plugins folder finally get rid of it, but still can't install the new version.

Error message:
Cannot complete the install because one or more required items could not be found.
  Software currently installed: Aptana Subversion Support 1.6.2.25864-797e7B2 (com.aptana.ide.feature.svn.feature.group 1.6.2.25864-797e7B2)
  Missing requirement: Aptana Subversion Support 1.6.2.25864-797e7B2 (com.aptana.ide.feature.svn.feature.group 1.6.2.25864-797e7B2) requires 'org.tigris.subversion.clientadapter.javahl [1.6.0,1.7.0)' but it could not be found

Something is wrong with Aptana's installation (their fault or a mess up). Seems that I have no choice but reinstall.
Thanks again for the support.