Problem with tmux

Asked by SabreWolfy

Just updated my Ubuntu 10.04 LTS server with several packages. After restart, I logged in and ran (as I always do) the command "byobu -R -D" to reconnect/create a session. Instead, I am now seeing a message saying "tmux: unknown option -- R" which I have never seen before. byobu --version reports "byobu version 5.1" and "tmux 1.5". I didn't know that byobu required/used tmux. Trying to apt-get remove tmux also indicates that byobu will be removed.

Edit: I see from the changelog that bug 909221 means that byobu depends on tmux and recommends screen. I also notice that simply running "byobu" creates a session and running it again later automatically reconnects to that session.

Question information

English Edit question
byobu Edit question
No assignee Edit question
Solved by:
Dustin Kirkland 
Last query:
Last reply:
Revision history for this message
Best Dustin Kirkland  (kirkland) said :

To keep using byobu with screen, you should run:
 byobu-select-backend screen

Revision history for this message
SabreWolfy (sabrewolfy) said :

Thanks Dustin Kirkland, that solved my question.