byobu always reconnects, how do I change it?

Asked by Gabriel de Perthuis on 2010-02-11

I'm used to having different byobu sessions with their own sets of windows. Now I get the same session in every terminal. How do I change this?

Question information

Language:
English Edit question
Status:
Solved
For:
byobu Edit question
Assignee:
No assignee Edit question
Solved by:
Gabriel de Perthuis
Solved:
2010-02-11
Last query:
2010-02-11
Last reply:
Gabriel de Perthuis (g2p) said : #1

By launching `byobu -m`.
Don't use byobu-launcher.
Run:

    byobu-launcher-uninstall

In your gnome-terminal profile settings (right-click, profiles, profile settings), in the “title and command” tab, check start a custom command instead of my shell, and put byobu -m in the command field.

(I'm doing the questions and the answers. Since I figured it out, I figured it might be useful for someone else. It used to be that `byobu` didn't try to reattach, but that changed in the past three weeks)

Dustin Kirkland  (kirkland) said : #2

Run:

 byobu bash

(or pick your favorite shell)

Gabriel de Perthuis (g2p) said : #3

`byobu bash` adds a window to an existing byobu sesssion if it finds one.

That prevents me from starting gnome-terminal from another term; `byobu -m` works better for that.

Dustin Kirkland  (kirkland) said : #4

Ah! Sorry, didn't realize you were asking/answering yourself here. Thanks for making the FAQ better ;-)