Can't boot from Command Line

Asked by reksveks on 2010-01-31

I have forgetten to change the BRUG theme so have be stuck with the command line, now i can't boot up linux to change the theme to one i can use more easily.

i have tried to use xnu_kernel64 to boot up the linux kernel however it gives an error.
Would be extremely grateful for a quick reply

Question information

Language:
English Edit question
Status:
Solved
For:
burg Edit question
Assignee:
No assignee Edit question
Solved by:
reksveks
Solved:
2010-01-31
Last query:
2010-01-31
Last reply:
2010-01-31

This question was reopened

bean (bean123ch) said : #1

xnu_kernel64 is used to load OSX kernel, the command you should use is linux, for example:

set root=(hd0,1)
linux /boot/vmlinuz root=/dev/sda1
initrd /boot/inird.img
boot

You need to change (hd0,1) and /dev/sda1 to the partition containing linux. If you are not sure, use "ls -l" to list all available partition and look for partition type ext2.

Some OS uses different name for initrd, if you encounter a file not found error while executing initrd command, use "ls /boot" to see what files are inside /boot directory and you can be able to pick up the real name of initrd image.

bean (bean123ch) said : #2

oh sorry, there is a problem with the above example, it should really be:

set root=(hd0,1)
linux /vmlinuz root=/dev/sda1
initrd /initrd.img
boot

reksveks (reksveks) said : #3

Thanks for your extremely quick reply however when I follow the method given but I get the following error

target filesystem doesn't have /Abingdon/init.
No init found. Try passing init=bootarg

then I go into some called busybody v1.13.3
P

reksveks (reksveks) said : #4

This is still unsolved

reksveks (reksveks) said : #5

Sorry; i found out the problem which was the root that i chooses was incorrect not sda1 but sda5. Thank you so much for your help though.
Extremely Grateful
Reksveks