burg doesn't work after having installed it

Asked by Abominable Snow Tux on 2010-07-19

Hello, I installed burg, but when i boot, grub2 starts instead of burg.
I tried to change the resolution, or also the theme, but nothing happens.

This is my default/burg:

# If you change this file, run 'update-burg' afterwards to update
# /boot/burg/burg.cfg.

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX=""

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
#GRUB_SAVEDEFAULT=true

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
# In the boot menu, use hotkey 'r' to popup a resolution selection menu.

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

# GRUB_THEME's value can be 'saved' or a specific BURG theme name, you can also
# set it to the pathname of a GRUB2 theme file.
# In the boot menu, use hotkey 't' to popup a theme selection menu
GRUB_THEME=saved

# GRUB_FOLD's value can be 'saved', 'true' or 'false'.
# In the boot menu, use hotkey 'F7' to show the full list, 'f' to toggle
# between folding modes.
GRUB_FOLD=saved

# Add user with burg-adduser, then use GRUB_USERS to config authentication.
# The following example means user1 can boot Ubuntu, no password is needed to
# boot Windows, user1 amd user2 can boot other OS. Superusers can boot any OS
# and use hotkeys like `c' to enter console mode.
#GRUB_USERS="*=user1,user2:ubuntu=user1:windows="

# For a complete list of supported variables, refer to this wiki page:
# http://code.google.com/p/burg/wiki/ConfigurationVariables
GRUB_DISABLE_LINUX_RECOVERY="true"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_DISABLE_OS_PROBER="true"
GRUB_GFXMODE=640x480

I saw many users that in this period have the same problem, so i think this might be a bug o a recent update.

Question information

Language:
English Edit question
Status:
Solved
For:
burg Edit question
Assignee:
No assignee Edit question
Solved by:
Abominable Snow Tux
Solved:
2010-07-20
Last query:
2010-07-20
Last reply:
2010-07-20
bean (bean123ch) said : #1

Perhaps you forget to run burg-install or update-burg ?

I understood the problem... I used burg manager (http://www.sourceslist.eu/burg-2/burg-manager-configurare-e-installare-il-burg-non-e-mai-stato-cosi-semplice/ ) but i thought that this do everything in order to installa burg, instead i solved with this comand:

sudo burg-install /dev/sda && sudo update-burg

which is that you suggested me.

Thanks. (and i'm sorry for my english)