Auto rotate?

Asked by Chrys on 2016-05-06

Correct me if I'm wrong, but I thought budgie was against the idea of a tablet. Instead focusing on a traditional desktop.

Funny thing is, my 2-in-1 laptop is actually rotating on it's own. No other distro I've used has done that without massive configuration(although, I've used it mostly as a traditional laptop anyway).

Who'd have thought that the Desktop environment that pushes for the traditional desktop would be the one that works well with a 2-in-1?

Question information

English Edit question
budgie-remix Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
fossfreedom (fossfreedom) said : #1

autorotate isnt a tablet thing - I use monitors that you can turn from landscape to portrait and the desktop should rotate.

There certainly has been alot of work in this area by the GNOME devs - since budgie using GNOME components it has just inherited this capability. This is good news!

Chrys (chryscy) said : #2

Disregard my comment then. I never saw the feature in any release notes, so I just assumed. Oh well, kudos to the GNOME team.

fossfreedom (fossfreedom) said : #3

yeah - thanks for the testing report - I've passed this back to the budgie team upstream and they are very impressed :)

Daniel Gomes (gomes-ortmeier) said : #4

Hi. This is happening on my laptop when using it on my lap. As you can imagine, it can get very frustrating trying to use the laptop on my lap and the screen keeps rotating as if it were vertical.

Is there anyway to turn this off or lock it to landscape?


Daniel Gomes (gomes-ortmeier) said : #5

Found the solution online:

On some systems with hard disk accelerometers that button appears even if your device doesn't support screen orientation detection. If that's the case you can disable the gnome-settings-daemon plugin via gsettings:

gsettings set org.gnome.settings-daemon.plugins.orientation active false


Seems to have worked for me

fossfreedom (fossfreedom) said : #6

+1 Daniel - nice solution.

fossfreedom (fossfreedom) said : #7

N.B. on 17.04 the key has changed: gsettings set org.gnome.settings-daemon.peripherals.touchscreen orientation-lock true