Boot-Repair scans system indefinitely, what can i do ?

Asked by YannUbuntu on 2012-10-09

After launching Boot-Repair, the "Scanning system" little window appears, the pulsate bar moves, but this situation remains indefinitely.

What should I do ?

Question information

Language:
English Edit question
Status:
Solved
For:
Boot-Repair Edit question
Assignee:
No assignee Edit question
Solved by:
YannUbuntu
Solved:
2020-04-27
Last query:
2020-04-27
Last reply:
2020-04-27

This question was originally filed as bug #1064323.

Rob Hills (rhills) said : #1

Oops, should have checked the terminal output before my previous post:

ubuntu@ubuntu:~$ /dev/mapper/isw_cgjfhjagba_HW_RAID_0: unrecognised disk label
/dev/sda: unrecognised disk label
/dev/sdc: unrecognised disk label

So, it appears it isn't related to /dev/fd0 at all.

YannUbuntu (yannubuntu) said : #2

This is probably due to the hanging of one of the tools (parted, fdisk, os-prober, mount...) used by Boot-Repair.
Example that shows it may be due to parted: http://ubuntuforums.org/showpost.php?p=12385060&postcount=7

If you meet this problem, please check possible errors in the output of the 'sudo boot-repair -d' command.

WORKAROUND:
Some users reported the problem was solved after:
- disabling the floppy drive in the BIOS
- or rebooting the PC
- or fixing the filesystem ( http://forum.ubuntu-fr.org/viewtopic.php?pid=11056641#p11056641 )